Cannot update AntiVirus

I did as you said, but the problem remains. Thank you anyway.

Would it be possible for you to answer the question posted above please.

  1. When I try to update CIS from within the application it immediately fails with:

“Error: 0x80010105 - The server threw an exception.”

And how can I solve this error?

  1. I tried downloading the AV database manually, and CIS fails the same way

  2. I don’t know how to verify the IP addresses that CIS is attempting to connect to when updating.

Could you give me some advice?

Please take a screenshot of the error and attach it to a post.

2. I tried downloading the AV database manually, and CIS fails the same way

Just to confirm, you tried to download from the AV database from:

Using a browser and it failed? If so, did you receive any messages in the browser?

3. I don't know how to verify the IP addresses that CIS is attempting to connect to when updating.

Could you give me some advice?

Open an command prompt and type netstat -ano as you perform an update. You can copy and past the results in a post.

I post the screen shot as an attachment.
When I tried to visit Comodo Forum , I sometimes received an error “Could not connect to remote server”, but sometimes I will get a slow download of about 10kB/s for the file. So I use some download tool to download the AV Database and place it in the scanner file in Safe Mode, then I restart my PC and tried to update, but the problem remains.
The failure comes so quickly that I may not be able to type netstat -ano as I perform an update… I typed once before an update and I tried to type as soon as I press the update button. The result is attached, too.

[attachment deleted by admin]

The first thing you should try is temporarily disabling IPv6 as this is know to cause download problems wit the Comodo site.

  1. Open network and Sharing centre
  2. Select Change adapter settings
  3. Select you network adapter and select properties
  4. Remove the tick from the IPv6 box (see image)
  5. Disable then re-nable the adapter
  6. Try to download.

[attachment deleted by admin]

I followed your steps, but it didn’t help. And strangely while my ipv6 connectivity shows “no network access”, I’m still using ipv6 address according to some test website.
I used this command to access ipv6: netsh int ipv6 isatap set router

[attachment deleted by admin]

ISATAP is a tunnelled IPv6 protocol which uses a different address format to the one seen in your netstat. Would you mind posting an ipconfig /all from the command line and also another netstat -ano taken whilst doing an update from within CIS.

I would say, however, the fact that ypu’re having problems downloading via the browser and also via CIS, would suggest a more general problem not something CIS specific. Also, you are getting a connection, albeit a very slow one.

That aside, it would be helpful if we could get some feed back on the CIS error message. Knowing it’s precise meaning would help identify the problem…Mods :slight_smile:

I attached the results I get from an ipconfig /all and an netstat -ano.

I have to admit that the network connection between my school net and the Internet is sometimes very slow.

And I don’t know how to get feed back on the CIS error message…

[attachment deleted by admin]

You’re still trying to connect over IPv6, which I’m pretty sure is the issue. Can you please make sure you disable IPv6 on the network adapter, before trying another connection. It may also be useful if you temporarily disable the Teredo IPv6 tunnel interface. To do that, from a command prompt type:

netsh int teredo set state disabled

To re-enable:

netsh int teredo set state client

Once you disabled IPv6 on the network adapter and also the tunnel, check ipconfig /all and make sure your main adapter doesn’t have an IP address starting with 2001. Try to update.

Do you mean this?

[attachment deleted by admin]

More or less. I didn’t notice on your previous ipconfig that ISATAP is also using a 2001 address… Please temporally disable this as well, before trying an update.

netsh int ipv6 isatap set state disabled
netsh int ipv6 isatap set state enabled

Out of interest, which web browser are you using?

It doesn’t seem to work…

I’m using Opera most of the time and IE sometimes. I also have FF and Comodo Dragon installed in case I need them.

[attachment deleted by admin]

That’s interesting. Stood another version of CIS?

Was any problems?

Or you just put a new one?

Unfortunately, we’ll have to wait until someone can find out what the error code refers to. However, as I mentioned earlier, because you’re having problems connecting generally, It suggests a problem out side CIS. Although you also mentioned you were having a problem after you manually downloaded the database?

I have removed the old version before I install the CIS6. I don’t have any trouble using the old one.

Are you using a VPN?

No, I don’t think it is using VPN to use Internet service provided by my school.;prev_next=next

This look - at the bottom. Page 2

After I manually downloaded the database using some other download tool and imported it, the problem remains. I cannot directly access the AV database. Would it help if I try to repair my win7 system?