Cannot uninstall or re-install

I have Vista Home Premium, with Comodo CIS_Setup_3.5.57173.439_XP_Vista_x32.exe

I saw the red exclamation mark in my Comodo system tray icon. The Comodo diagnostics failed, but produced a report, which I saved.

I uninstalled Comodo using Control Panel.

I double clicked on the installation file, CIS_Setup_3.5.57173.439_XP_Vista_x32.exe

The message was “Comodo is already installed. Do you want to uninstall”. Yes

However, nothing actually happened.

I would be grateful for any advice

Download Regcleaner, install it and delete the Comodo registry entries it shows. Then try again.

Does that help?

RegCleaner worked fine. Comodo now installed. Thanks for the tip :slight_smile:

Here are some bits of info that might be off-topic, but might be useful to someone:

  1. I ran RegCleaner under the account named “me_Administrator”. This is an account that I created with Administrator privileges. I right-clicke on the RegCleaner icon, and selected “Run as administrator”. I selected the Comodo entries to delete. RegCleaner said that it could not proceed, because of file access problems.

So, I switched to the “Administrator” account. This is the default administrator account that is normally hidden and does not appear on the login screen.

Everything worked fine. So that means that RegCleaner sees a difference between the “Administratror” account and the “me_Administrator” account.

  1. While I was waiting for a response to my post, I ran CCleaner to determine whether there were orphan entries. CCleaner found a few entries, but no “Comodo” entries.

That seemed suspicious to me, so I manually entered regedit. I found several (20?) entries for Comodo. I did not delete them manually, because I wanted to know what the forum users said.

So, one or more of the Comodo entries must have fooled CCleaner into thinking that Comodo was still installed. I wonder which entry that was?

  1. After using RegCleaner, I then tried to install Comodo in my “me_Administrator” account (because this is the account that had the original Comodo problem). It was obvious that the installation was going to proceed normally, but just to be on the safe side, I switched to the default “Administrator” account and ran the installation from there.

Ccleaner is not a very thorough cleaner. it is safe to use though. For a stronger cleaner you can try Comodo System Cleaner: .