Cannot Uninstall CIS

I’ve tried the guides in the forum on how to remove/uninstall Comodo but none of it worked.

The reason why I tried to uninstall Comodo is because it has never worked properly since I first installed it.
A notification windows 10 keeps popping up saying you don’t have an antivirus or firewall installed,
even tho Comodo firewall is stately and antivirus is safe mode running.

I tried uninstalling CIS, then after restart it was still running?
ran ciscleanuptool and red letter messages come up saying, access denied. on files.

I even tried several shredders and file permission controllers and autorun to take back comodo files but
were unable to, comodo files are invincible !!! access denied.

Now most of CIS is gone, cis.exe, cmdagent is still there and a message pops up constantly on my screen
saying cannot find comodo themes default.set. I cant have this popup all the time on the screen.


try to run on Safe Mode if not work on normal Windows

Hi comodius1st,

Sorry for the inconvenience.

“Windows popups saying antivirus and firewall is disabled though CIS is being running” is known issue and the team is working on it.

Could you please refer the below link to download the CIS uninstaller to remove CIS.;msg869600#msg869600


  1. Download the corresponding CIS uninstaller bit type according to your system bit type.
  2. Make sure to restart your machine twice while using CIS uninstaller as it requires twice restart to uninstall CIS.

Below is the link to download the latest version of CIS.


Didn’t I mention I did this already?
Actually about 18 or 19 times.

Thanks for replying tho, I appreciate the help
I really need this working, I need to take screenshots of screen for work.
But cannot because of comodo popup.

I also tried downloading CIS installer and tried to install new versioin but
nothing happens when I Run cispremiuminstaller. Not even using admin priv.


Hi comodius1st,

Sorry for the trouble, so still cis.exe and cmdagent.exe still running right ?
We are checking on this and will update you.


Have you tried the suggestion mentioned by kyl to boot your computer in Safe-mode and then run ciscleanuptool in Safe-mode and let it reboot your computer twice (make sure it reboots in Safe mode twice).

Ok almost all of it is gone, except Windows is looking for Comodo Antivirus and Firewall.
I Went into registry and it won’t allow me to remove it from there.

How I got rid of cis.exe, cmdagent etc ?

I tried going into safe modes but only one seemed to work, Repair Mode.

I installed three Take Ownership programs
I installed five Shredders.

I went into Repair mode.
Took ownership of each file in Program Files\Comodo, shredded
Did search in windows explorer for cmd*.*
found some in
took ownership, shredded
reran ciscleanup tool while in repair mode.
Restarted computer.
reran ciscleanup tool.

Only thing left is windows looking for comodo antivirus and firewall at startup. The rest is gone whew!
I really like Dragon, secure shopping and Comodo low overhead.
But I think I might try another program now, sorry guys.


u can try AutoRun64 from MS’s sysinternals tools for startup issues you’ve mentioned