cannot turn monitoring on

I have no idea of what happened, nor does anyone that was on the computer today. Everything is turned off: Application Monitor,componet monitor, network monitor. I have clicked “on” on each one, but “off” stays marked. I have clicked on advanced, and none of boxes are checkmarked. I have also clicked on “restore”. How do i get these turned back “on”, and how can i get the componet monitor back to “on” or “learn”? Again, no one says they did anything with comodo.


Can you open CFP, click on SECURITY - ADVANCED - MISCELLANEOUS and turn OFF “Protect own registry keys from unauthorised changes”. Reboot the PC and once rebooted, check the registry protection is still OFF. If so, see if you can now change the status of the monitors.

Let us know how this turns out.

Hope this helps,
Ewen :slight_smile:

I am having the same problem, I installed CPF a few days ago and now its telling me none of the monitors are turned on, when I try to turn them on they will not?

Is this a bug? IS there a fix or patch? I am worreid my machine is not protected.

Cheer for any replies in advance!

Yes, it is a common problem since Comodo began coding their own installer. They are not offering any solutions to the problem. They’re too busy updating the multi-language Help files to make the installer install properly, or the program work properly.

I have now tried to install CFP, but it does not work at all.

  1. I tried to uninstall, and reinstall. It told there is an old version installed on the system, uninstall first (but there was nothing)
    2,. comodo cannot initialize the monitors, does nothing.
  2. from event log I see CmdMon failed to load
  3. from registry I see: HKLM/System/ControlSet001/Services/CmdMon/ImagePath = System32\DRIVERS\cmdmon.sys
    this is wrong, N:\windows missing (Yes, actually SystemRoot=N:\WINDOWS)
  4. after correcting the registry entry nothing changed, comodo CPF does not work.

It is a fresh new install of Windows XP Pro SP2, just the system drivers installed.

pan, I’m not certain but it appears that there is a problem with installing CFP on a different drive other than C:. See if this manual uninstall thread helps.

Thank, that can be true.
Unfortunately uninstalling is not a solution, I want to install (and use) it!
On C: it seems ok, but on N: there are a lot of problem.
Actually I installed an earlier version of the firewall and that one works. After that I have upgraded to the last version and now I can use it, but again, it does not work for another user- there are no working monitors, and nothing can be set.

I think the last version is incomplete, cannot be safely installed, cannot properly uninstall itself …

The disabled monitors issue will be fixed in version 3.