Cannot remove Google chrome add-on clickclean from sandbox (4.0.135239.779 x32)

why is clickclean.exe being put in the sandbox it is safe O0 ??? ???

Re ‘safe’ could I just check whether you mean it is in ‘My Safe Files’ or defined as an installer/updater? If not it will only be considered ‘safe’ by the sandbox if it’s on the CIS whitelist (vendor or file).

Could I also check how you know it is being sandboxed. If you are using ‘My Pending Files’ please look at the logs to ensure it is actually being sandboxed.

To take it out of the sandbox, please consult the relevant FAQ

Many thanks & best wishes


Same issue everytime I close my Chorme browser

I think is a BUG wel I don’t know why moderators put every issue here
The problem is for every program CIS can’t read the certificate ti see if it is trusted or not, every program you can’t select the vendor on the sandBox popup is the same story

You can see the issue exactly in this pic:

CIS put the application in My Own Safe File and this is perfect, read exactly the vendors but on pop-up allert this great info are missed and you can’t select vendors as trusted !!! Why this 2 behaviour, here we are the focus of the issue !!! Telling SanBox to run the application out of the box is onli a matter of time 'cause everitime you use the application CIS repeat the warning

Sorry that you are having this problem.

I think part of what is happening is as follows:

CIS knows the file from its ‘hash’, and knows it to be safe. CIS has taken the vendor from the file properties because the file is not signed, so it’s not sure about the vendor. CIS will not let you add a vendor unless that vendor can be properly identified from a code signature.

But that does not explain why you are getting the sandbox alert. One possibility is that you have manually sandboxed Chrome, and so whatever it runs is being sandboxed as well, even if it is a safe file. To understand this please have a look at the “Introduction to the Sandbox”, link in my signature. If this is the problem you can get round it, while maintaining security, by manually sandboxing your add-on. Or else you can take Chrome out of CIS’s sandbox and rely on its built in sandbox, ‘incognito mode’.

Have you manually sandboxed Chrome (ie added it via ‘add a file to the sandbox’ or ‘run a file in the sandbox’) or perhaps is chrome being incorrectly automatically sandboxed?

Best wishes


unfortunately not, in my sandbox area I have only a portable browser QTWEB I use for study sandbox behaviour and trying understand how it works ;D.

I though possible Chrome was suddenly sandboxed by cis but on the sandbox patterns and on the vritualroot pattern there is not (oly Qtweb obviously)

I don’t know why I can’t select to trust this vendors, and not having this possibility CIS rememer the answer everytime i close Chrome
Could be an incompatibility with the Chrome Sandbox? Well I have not FireFox on this pc to see if using Click&Clean FF extension have the same issue or not

Thanks for your interest in the issue, your 3d is very intersting, I hope some Comodo boss can explain how this new feature works exactly, 'cause Help File seems to be oldier and not perfect talking about SB

[Snipped a couple of previous posts because I tried out the ideas in them and they did not work]

However I have confirmed that the following is correct, by using sigverif.exe to check whether the file is signed:

But this does not, as noted above, solve the sandboxing problem.

Having installed Clickclean, file here, I have also confirmed that none of the normal ways of unsandboxing a file (in the unsandboxing FAQ) work for ClickClean.exe, apart from manually sandboxing both it and chrome (see below). This does not of course unsandbox clickclean but it does supress the sandboxing alert.

I have also been able to replicate the sandboxing alert and I get a ‘run as’ OS dialog as well. I can replicate this by setting the clickclean add-in (using extension/options) to run the external clickclean.exe application when the browser closes, then closing the browser.

My best guess is that it is the extremely long path to the excutable that is causing the problem. Although a my safe files entry is made it appears that CIS has difficulty acting on it.

One approach that does seem to work is to sandbox both clickclean.exe and chrome at the unrestricted level with virtualisation turned off. If you do this, you get no sandboxing alerts, and it appears that you can run clickclean sucessfully using the ‘run-now’ button under clickclean options. However I am not sure clickclean.exe runs if set to run after closing the browser. You may want to experiment to check this.

In any case this seems to me to be a bug, so I will move this accordingly. Please add system details as requested in the Bug Reports section.

My system details are:

  • CIS version: 4.0.135239.779 x32
  • Your Operating System (32 or 64 bit, Service Pack revision, and account privs: XP SP3 32 Bit, admin account (on Pentium 4 CPU 3Ghz, 4Gb RAM)
  • Other Security and Utility Software Installed: See appended config report for details. Usually: Comodo - CIS, CVE, CIV, CLP, CSE, CAS, IVault; Other- Filezilla, Wallwatcher, Sony Ericsson PC software, Actual Window Manager, Routerstats, Revo, Process Explorer, Google Desktop, Process Tamer, Process Explorer, Kiwi Syslog, Idrive, Clipmate, Hotspotshield, Stuffit
  • Step by step description to reproduce the issue: Please see post
  • How you tried to resolve the problem: Please see post
  • Upload Memory Dumps on crash if you encounter any: N/A
  • Attach screenshots to your posts to clarify the issue further: Please see other posts in topic
  • Virus database version: Please see appended config report
  • Any other information you think that might be useful. CIS settings: See appended config report for details.

Best wishes


[attachment deleted by admin]

thanks mouse1 for your big effort
in addition to your perfect post explaining the issue i descover that, see the image

No Chrome patterns on SANDBOX or VRITUAL, no Chrome in my sandboxes program, but according with D+ log Chrome is sanboxed ??? and so every extensions too

the strange is that files I dowload with chrome are here not sandboxed, on my real pc, file downloaded via chrome are in my HD normaly

Now I try to say to CIS still continue Click&Clean on sandbox area (on pop-up alert) and Click&Clean is not present, simply vanishing :o no pattern in Vritual, no name on my sandboxed program, nothing !!

Whell I use Chrome dev, seven 32bit Ultimate, CIS set in Proactive Security, but I think the issue involved CIS Sandbox incompatibility with Chrome inside SandBoxie

Please Comodo developers investigate !!! I hope this additional info could help you

OK this one is easier. (I think ;))

When CIS automatically sandboxes something its sandboxes it limited without virtualisation.

You can find out all about this in my introduction to the sandbox. Just click the link in my signature.

Best wishes


??? on help said
Limited - Only selected Operating System resources can be accessed by the application. The application will not be allowed to execute more than 10 processes at a time and will be run with out Administrator account privileges. The restrictions on usage of system memory, operation with virtual file system and registry and execution time defined in Advanced Settings will be imposed

If you put a program in sandbox in advance setting you can se virtualization is enable (limited too)

you think Limited not virtualize?

For the other question you have right, D+ log said so because till I don’t choose on the pop-up application is consider under sandobox, that is why the log register it

I understand your confusion. If sandboxing is automatic, the limited policy is applied, but without virtualisation.

The help text should make his clear, but doesn’t!

Best wishes


ohhh pitty , now is clear !!! I hope Comodo change Help too

Hello, can you please tell your translator to give you an updated translation file? (as i see, you got a gui bug as well). Also, i had troubles with WinRAR, so maybe you got an alike issue: try to figure out what other files this program is using and add ALL of them to the safe files list (this did the trick for winrar, i’ve added the whole directory to the safe files).

May be worth trying - even if the problem is the path length, as the directory path is shorter than the file path.

Also the plug-in is a .dll which runs the .exe. So, as I say worth trying.

BTW have you considered whether it is sensible to use a browser cleaner with an unsigned .exe? Seems risky to me. Perhaps try Comodo’s system cleaner. Works well for me!

[Edit: I’d avoid doing this to the main browser directories though, for security reasons - try to limit it to click-clean only]