cannot remove file from sandbox

I installed an image editor program on 64 bit win 7 desktop and ran it . It said it was isolated or restricted. i clicked do not isolate it again. It was isolated again. Now it will not run even if i disable comodo

I cannot add it to trusted files. I do as I should it does not happen
It is not in blocked files
It was in or i put it in hips rules. Would not run under any setting. Cannot remember all I tried
Cannotv add vendor to trusted vendor it is not signed. It is legit program though

Not sure how but i managed to remove it from unrecognised files and tried again. Now it is sandboxed as fully virtualised but does not appear under advanced\defense\ sandbox

Why can there not be an easy way to free it like a right click in nthe logs where it says sandboxed. If i do not get this frew will have to uninstall comodo before new firewall ready

How can i free it from comodo sandbox for today? I am getting rid of this comodo it does not work any more

Tried it on 32 bit vista laptop. same thing it isolated again even when told not to. Worked third time. Then it worked. It does not learn do not isolate again

Hi david banner,
What happens when you try to manually add the file to the trusted files list?
Adding files to Trusted Files list-Comodo Help


Hi Captain. Nothing happens. I go through the process add/browse to file and click the file and click open. And Ok. But it is not there in trusted files. Just now I entered it in hips rules with use ruleset/allowed application. Still won’t run
Tried this too

This not learning do not isolate again is repeated several times on this forum. That is why I am getting rid of Comodo until it is made simple to unsandbox a file and until it works

Hi david banner,
Has it been added to the ‘Auto Sandbox’ list?
Configuring Rules for Auto-Sandbox-Comodo Help

Other than that, I am not sure what is happening at this stage.

Kind regards.

No not there either. No auto sandbox in 7. What is happening is comodo does not work. I have ben unable to use that program today so tomorrow will uninstall comodo

When a file is isolated it should appear in unrecognised files. It is not there. Is there anywhere in registry blocked files can be cleared?

I am asking one of the technology journalists to look into this charade.

Do you have security programs installed that run in the background alongside CIS?

As always make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

i do have other programs. NAV.WinPatrol,MBAM. But i have these on the laptop too and thisn program works on it. But it did take three attempts to get comodo to learn do not isolate again
It is a fairly fresh install no leftovers. Trial programs are tried in sandbox first C:\VTRoot\HarddiskVolume2.

The issue is the file cannot be removed from the sandbox. It will not even run when i boot with comodo removed from starting with msconfig. How can it stop the file running when it is not active. Is the sandboxing recorded in the registry

There are several threads on similar issues, comodo does not learn ‘do not isolate again’.I say this is a problem with comodo and since comodo ignore it i am moving to a different firewall. i sent Melih a pm. he did not reply

I am awaiting delivery of a new firewall and want this file free without having to do system restore because i do not want to be making changes to this fairly fresh install. i do not need to uninstall my av. i need a firewall that works as it should including as i have said several times an easy way to remove a file from the sandbox without having to add it to trusted. surely this is possible but it is ignored. i do not intend to spend my days digging in the bowels of comodo for what should be a simple click

Is MBAM running on access?

The issue is the file cannot be removed from the sandbox. It will not even run when i boot with comodo removed from starting with msconfig. How can it stop the file running when it is not active. Is the sandboxing recorded in the registry
With Comodo removed it should not get sandboxed. Apparently there are other factors at work. Likely candidates are NAV, WinPatrol and MBAM.

MBAM is running all the time, is that what on access means?. CIS and the file in question are set to ignore in MBAM and NAV. Winpatrol I do not see how it would block it, it always asks what to do as far as I know

Hi Eric, thanks for your help with this discussion. :slight_smile:

Hi david banner, Real time scanning equals on access. [url=]Real-time Scanner Settings-Comodo Help[/url]
The real-time scanner (aka 'On-Access Scan') is always ON and checks files in real time when they are created, opened or copied....

While on the real system, have you tried navigating directly to ‘C:\VTRoot’ in search for the file?
If found you could Copy/Paste it to another location.

The file is on the real system. I was only making the point there are no left overs on my computer. I TEST files in the C:\VTRoot’. Thisfile is onthe real system and caught in the auto sandbox. I do not have comodo AV only firewall

I realise that you have CFW only, I was just using Comodo AV as an example of what ‘on access’ is due to this question.

I imagine this must be irritating for you and I do wish we could find a solution.
Have you tried adding the file to the Behaviour blocker exclusions list?
To define exclusions-Comodo Help

yes added to exclusions. Had to do system restore to fix this. Goodbye comodo. Getting a real firewall