Cannot register license provided by Comodo

I’ve got problems activating the license using the license string provided by Comodo. I copied and pasted the string from the email as instructed, then click on “Activate”. I got an error message. Some of you may face the same problem. Please advise how you resolved this; what are the steps I need to take?

Other than that it’s a cool free product. Thanks.

Welcome to the forum!

And what error message do you got??

If it was error code 2146697211 or 2146697208, see this link for help:

Otherwise, tell us the error message you got, and we will try to help you ;D


Would you be able to advice any other tips? I’, still experiencing the problem.

I received the following error:

“An error has occurred. Error -2147221231 : ClassFactory cannot supply
requested class.”

Support has asked me to check the following files in the ‘[Windows]\System32’ folder:

The “msxml3a.dll” was missing. I downloaded a copy from the web and saved it in the directory. Then tried activating the license again; but failed. Same error message appeared.

I did check out the information in the URL you supplied, the setting for my IE is the same.


I think you should go to Comodo Support, register on their system & create a Ticket on this.

Same thing happened to me when I tried to Activate Comodo Personal Firewall on an Acer 3613LCi, operating WindowsXP:

Entered the Activation Code, then clicked ‘Activate’ … Windoze promptly (and repeatedly) displayed a ‘fwconfig’ window indicating: “An error has occurred, Error - 2147221231: Class Factory cannot supply requested class”

so … having uninstalled Norton’s Firewall and Anti-Virus, the Acer is now essentially naked to the Internet’s nasties, because Comodo can’t or won’t activate (though it does seem to be doing something, as it presented a ‘normal’ Comodo warning for Acer eManager tryiing to act as a server).

I was hoping the user forums might have a ‘quick fix’ …

oh well, at least I know I am not alone in this predicament …

Guess I’ll try Support.


Also check this article in the knowledgebase:


I’ve had problems registering/activating as well. Same error 2146697211, but a different message saying just “unknown error.” I opened a ticket on the problem and just this morning got an e-mail reply from Comodo support. Apparently lots of others are having problems with activation, so an updated version of Comodo will be released later this month. It will not require activation to work.