Cannot Reach Websites After a Few Comodo Recommended Firewall Tweaks

A. When I made changes to firewall from this page: “Firewall Setup For Maximum Security And Usability, Firewall Set Up, Spyware Scan”, except for the stealth port change, after I saved changes, there were several web sites I could no longer connect to. (Varies from issue to issue)
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
I was able to repeat this a few times and whatever configuration I made the changes to would no longer work. I had to import a new config from Comodo folder.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:I followed the recommendations from top to bottom from this Comodo firewall quick start page: Firewall Setup For Maximum Security And Usability, Firewall Set Up, Spyware Scan, with the exception of stealth ports, which I did not do.
One or two sentences explaining what actually happened:
After the changes were saved, I could not visit many of my websites, like duck duck go.
One or two sentences explaining what you expected to happen:
I expected to be able to not have my web browser functionality broken from what appeared to be just a few simple tweaks recommended by Comodo.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not aware of any incompatibility problem.
Any software except CIS/OS involved? If so - name, & exact version:
FYI, Windows firewall was turned off. Malwarebytes premium running no problem.
Any other information, eg your guess at the cause, how you tried to fix it etc:
I don’t know. A bug as far as I would guess. I recently upgraded from Win 10 Home to Pro.

B. HP PC AMD Athlon II x4 645, 3.1GHz. Win 10 Pro 1809. 10 GB ram.
Exact CIS version & configuration:
CIS config-firewall security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV, firewall, viruscope and website filtering.
Have you made any other changes to the default config? (egs here.):
I don’t think so.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
No, CIS 12 is my first.
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 10 1809 64 bit, UAC on, admin. No virtual machine used.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebytes Premium b=Used to have Avast internet security.

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

Did you check the firewall logs to see if any blocked events are being logged? It probably has to do with enable anti-arp spoofing setting.

Hey futuretech,

That was it. anti-arp spoofing. I was following a setup guide from: Firewall Setup For Maximum Security And Usability, Firewall Set Up, Spyware Scan
I went back and enabled the settings one by one and when I got to anti-arp spoofing, that’s when the trouble started. I ended up uninstalling Comodo CIS and internet essentials. When I reinstalled, I un-selected all the options at the setup screen this time. Now when I run diagnostics I don’t have any errors. The first time I installed Comodo CIS right over Comodo Firewall and that may have caused issues.

Unfortunately, I am a novice when it comes to firewalls. I have been relying on Avast AV and Windows firewall for too long. :slight_smile: This seems like a nice package, but a steep learning curve for those wanting to harden their system beyond default setups.

Thanks for the help