cannot install/upgrade

Well, I have been using comodo firewall for a long time, and wanted to get the antivirus going. So I uninstalled my Symantec AV first and then tried installing/upgrading the antivirus part of CIS.

Everytime I install, it throws an “oops you found a bug please report it” error.

I’ve tried uninstalling, reinstalling
uninstalling with revo, reinstalling
uninstalling, finding/deleting every file/folder with ‘comodo’ in its name, reinstalling
using the cleanup tool, reinstalling

In every case, after reinstalling, I reboot, find comodo not running, manually launch it, it says something is wrong; do I want to have it fixed, I say YES, then reboot and the firewall works fine… but still no ability to install antivirus.

Please help! I really don’t want to reinstall syamtec.

Add’l info:

WinXP SP3, AdAware and SpyBotS&D TeaTimer installed (but disabled for most install attempts) of CIS

Try cleaning out the temp folder before starting the installer. Does that help?

Hmmm, very interesting - closer but not there - and odd…

I ran CCleaner (does more than just remove tmp files)… then ran the Upgrade/Install program with antivirus checked. It unceremoniously exited “cfpconfg.exe” in task mgr…
so I manually exited the comodo firewall, ran the upgrade again, and no feedback. So, I manually started Comodo… antivirus was there, but no firewall. Ran the upgrade again, checked both Firewall and Antivirus, got the oops error, but upon manually starting comodo, all components are there… HOWEVER, when I tried to update Virus defs, got “Update failed. Error code 0x080070001. Incorrect function”.

Try the following procedure to see if there are left overs from previously uninstalled security programs.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

As it happens, I rebooted a few times after my last update, but before reading your reply, and it spontaneously was able to update the virus defs. Now, the only remaining issue is that the Windows Security Center does not recognize Comodo FW or AV, but I’m not terribly concerned about that (I had to tell it to not check for Symantec AV previously anyway, so its no worse than before).

In summary: I’m happy… Comodo FW and AV are installed. Your AV is less resource intense than Symantec’s AV, and it finds things Symantec missed.

Thanks for your help!

Try the following to fix the security center issue:
Open a command prompt by clicking Start → Run. Type cmd and click OK.

In the command prompt window, type NET STOP WINMGMT /Y and press ENTER.


Type EXIT and press ENTER to close the window.

Restart the system. Windows should start normally, but you may be prompted to restart the system once more to complete the changes caused by resetting the core repository. You may also need to restart once more if Windows Security Center still does not detect your security product.

Another good thing about CIS is that it will keep you clean. Prevention where it truly excels.