Cannot install CIS. Error:13. The data is invalid.

Tried installing CIS v4 from v3.0.25.378 one month ago. Failed. Uninstalled v3 using Revo Uninstaller. Complete uninstall. Failed. Let time pass thinking it might be a bug in v4. Hoping for newer version.

Tried again today. All 3 installation methods. Firewall, Windows, CIS (without antivirus, as I use AVG). Still same Error message.

Read piece on v3 to v4 conversion. Had already tried most of the advice. What to do?

I have a basic XP3 system that never gives me problems, despite dozens of programs installed, over 100.

Hi habilac,

after analyzing the logs we came to the conclusion that there are several leftovers of CFW 3.0 that are preventing the installation of CIS 4.1.

Please try to do the following steps:

  1. Run Start → Control Panel → “Add and remove programs”
  2. Find COMODO Firewall or COMODO Internet Security. If not found, go to p.5.
  3. Uninstall them
  4. Reboot
  5. Go to Firewall installation directory (c:\program files\COMODO\COMODO Firewall OR c:\program files\COMODO\COMODO Internet Security)
  6. Delete it
  7. Go to registry (Start → Run → regedit)
  8. Find and delete next keys:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion?\Uninstall\COMODO Firewall Pro
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion?\Uninstall\COMODO Internet Security
    HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
  9. Reboot
  10. Check all reg keys, files and directories do not exist
  11. Try to install CIS 4.1 with logs enabled

Hope it helps.

Please ask questions if you have any

Best regards,

Hi Comodo,

Thank you for your answer.

  1. I unplugged my computer from my ADSL modem. Next I will use Revo Uninstaller, the Advanced Mode, as it does a better job than the Windows Uninstaller. And then check to see if any Folders and Registry Keys that you mentioned need deleting still remain. Then I will delete those folders and keys.

  2. [Steps 1 to 4] Revo lists COMODO Firewall Pro, Version Uninstalled including registry keys and folders and files remaining. Rebooted the computer.

  3. [Steps 5 and 6] There was only the following empty folder, with no subfolders or files: C:\Program Files\Comodo . I left it as is.

  4. [Steps 7 and 8] I started Regedit, and looked for the registry keys you listed.

I did not find the first two keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion?\Uninstall\COMODO Firewall Pro

I found the third key, and deleted it:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion?\Uninstall\COMODO Internet Security
(Default) REG_SZ (value not set)
DisplayVersion REG_SZ 3.14.147648.588

I did not find the fourth key:

I found a very big key with subkeys similar to but different from the fifth key listed, with NO Firewall Pro subkey:

I exported this key to a .reg file which I am attaching to this email. I deleted this very large key.

  1. [Step 9] I rebooted the system.

  2. [Step 10] I checked that all files, folders and registry keys had been removed. They had all been removed.

  3. [Step 11] I attempted to install CIS 4.1 at the command line following the instructions in your previous email.

I did not get the Error screen !! I selected " Firewall with Maximum Proactive Defense ".

I accepted to join the Threatcast Community.

I chose not to use the COMODO Secure DNS Servers (as this is something I do not understand yet).

I clicked Install. I restarted my computer, and replugged it into the ADSL modem while it began rebooting.

Conclusion: CIS 4.1.150349.920 seems to have installed correctly. I can use Thunderbird and Firefox (latest versions).

Thank you for your help. I hope to have been useful to you and the Comodo community.


Is this the best way of upgrading to the newest version if you have a problem?

I’m just wondering if I should update this:

Since upgrading from v3 to v4 with my new machine, about 2 years old, did not present any problems, and since the upgrade from v3 to v4 on my older machine, about 4 years old, did, (both having Win XP Pro SP3, the newer French, the older English), I assumed the remnants of Comodo I found in the registry of the older machine, HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo, were from an installation of Comodo that was OLDER than 2 years ago, and probably not searched for by the registry cleaning segment of the installation process in v4. Note that my older machine has had Comodo installed from the very beginning, that is 4 years ago.

This is why I included an exported version of the above registry key in my email report, so you could look at it and determine which previous version of Comodo had created it. Note that the 5th key you asked me to delete included an additional \Firewall Pro subkey which I did not find. I nonetheless deleted the whole key after exporting it. This is another indication that the key I found was older and not looked for by the current upgrade process. I cannot explain why Revo Unistaller did not find it and remove it, as it included the Comodo name.

I did not follow your instructions to use the Windows uninstaller, but chose rather to use Revo Uninstaller freeware, which I have been using for 3 or 4 years now, for 2 reasons. 1) I trust it far more than I do the Windows uninstaller, and 2), you yourself recommended using it in your instructions for converting from v3 to v4.

I cannot recommend to you whether or not the method I used, Revo Uninstall, Advanced Mode, then looking for five specific registry keys you asked me to look for and remove, should be added to your instructions for upgrading from v3 to v4. This combination worked very well, as v4 installed without a problem. I would recommend it to any one who gets the same error message I did. It could also work with other v3 to v4 installation problems, but I cannot attest to this, my knowledge being superficial at best.

But this combination is relatively simple and compact, and it worked at the first try for me !! So who knows ? Maybe you could offer it as a quickie alternative.

Have the same error on XP SP2, then SP3 and tried to fix it a number of times over the past couple of months without any success. Followed this instruction and installed the software successfully. Didn’t use Revo at all.

Could you be more descriptive of how you tried? Did you try Chiron’s suggestion?

Great, I wasted time thinking my hard drive / RAM / CPU was corrupting data and tested them with a 24-hour stress-test! Can I have my time and money for electricity back, please? No? Then can Comodo GET A CLUE and write an installer that makes sense, please?!

Even Microsoft have more transparent error messages than this, and the installer is a later version than the one needing un-installing, no excuse for not recognising an earlier version and stating a simple error message like: “Comodo version 3 must be uninstalled before version 4 can be installed.” is there?

I mean, this is ignoring the fact that the whole point of auto-updates and automatic-installers is to do everything for the user, Comodo Firewall 3 nags the user to update and then fails to make it possible… pretty poor. This is a surprising, disappointing failure on Comodo’s part - for something that’s pretty easy to accomplish, too.

Some tech issues are a matter of working through complex, often-elusive technical issues, together with the general public (AKA unpaid ‘Beta testers’). I don’t criticise that when a product is offered free (although what Microsoft, Apple and the like’s excuse for it is, I don’t know…). THIS case is NOT one of those, and I’m severely unimpressed, Comodo. Why does everyone act like it’s an acceptable way for the software to act instead of directly criticising Comodo so they might do something better next time?

Hi Groovehound,
This subject about versions 3 and 4 are long gone history (necroposting).
Please don’t resurrect old topics without adding useful information.

Besides that any major version upgrade with any product it is advisable to do clean installs.

Kind regards from Captainsticks.

If you are trying to put an outdated version on top of a more outdated version,
how would you ever know if they fixed anything.