Cannot host games...

So I’m trying to host warcraft 3 games… I’ve set war3.exe to Allow all activities for this program yet I still cannot host no matter what, I don’t understand what the deal is and why even though I said for it to allow the application that it still tries to block incoming ports, hell, I can’t even become connectible via uTorrent


Ok So I did a little bit more digging, it would appear that somehow, even though I’ve enabled the ports, its still being blocked by Network rule 5.

here is the block log…

Description: Inbound Policy Violation (access Denied, IP = 71.72.., Port = 6112)
Protocol: TCP Incoming
Source: 71.72..:1286
TCP Flags: SYN
Reason: Network Control Rule ID = 5

If rule 5 is disabled, it works fine, Now I will include a screenshot of the rules I created just for this…
Mind you I had more, But I deleted them all to make sure it wasn’t a problem on my end.

I followed the instructions on the Blizzard site, but yet its somehow being blocked even if I do set them to allow all, I simply do not understand why rule 5 is not taking my custom rules into account.

been a while and still no reply? guess I’m done with your so called good firewall, what a joke.

Uninstalled, back to Outpost Pro for me..

Sorry you haven’t had any replys DarkShadow
Besides the application rules you will also need network monitor rules.
I am no online gamer but this is where I would start
This is a tutorial thread from the FAQ’s,668.0.html

Well, the joke was that you leave so quickly :wink:

I am sure if you give it more time, you would get an answer! Sending in a support ticket is another choice if you don’t get any answers in here.

I have a friend that host warcraft 3 games, so I know that it will work…but right know he is on vaccation, otherwise I could call him and ask after his rules in CPF.

Haven’t checked the thread, but maybe you can have some answers in this thread:,463.0.html

And this firewall IS good :wink:

thats just it, I’ve read almost all of that and still it would not work, so I really don’t know… I really tried to make it work but for some reason no matter what I did, it would still block incoming attempts to join my game…

the only workaround I found was disabling my firewall while playing, which does not work for me because playing games is kinda half what I do during my day, and being unprotected while designing a map and trying it out seems like a bit of a security hole for me.

Bluesman if you could find those rules sometime that he uses, that would be great and much appreciated, no rush or anything, I’ll keep messing around with it on my laptop, just gotta remember to fix my bootup to stop defaulting to knoppix and get on XP to reinstall the firewall.


The answer is in the log file, once you learn how to interpret it.

Description: Inbound Policy Violation (access Denied, IP = 71.72.*.*, Port = 6112) Protocol: TCP Incoming Source: 71.72.*.*:1286 Destination: TCP Flags: SYN Reason: Network Control Rule ID = 5

The critical factors are that it blocked an unsolicited request inbound to port 6112 (WC3, from memory, uses ports 6112 - 6119).

The network monitor rule you need to set up is as follows

Action : ALLOW
Direction : IN
Protocol : TCP
Source IP : ANY (this is whoever is trying to join a hosted game)
Destination IP : ANY (this is you)
Source port : ANY
Destination port : A range of ports - 6112 - 6119

Once this rule is added to the network monitor and moved above the default block rule, providing you are running WC3 at the time (network monitor will only open ports IF there is an application running that needs that port), inbound requests will be allowed and you and your mate can pillage and plunder to your hearts content.

If you carefully go through the rule line by line, you should be able to see how it addresses the blocking that the network monitor performed. Once you get your head around this, creating rules for games isn’t really that hard.

Hope this helps,
Ewen :slight_smile: