Cannot get ESM to install

Installing ESM 1.5 on a W2008 x64 domain server. I always get to the window where the Comodo ESM service is starting, then the install routine hangs up or times out, the CesmService service fails to start, and I have to cancel the install and try it again. I’ve done this multiple times, tried different SQL ports, even tried install on an alternate server and I cannot get 'er done. I installed SQL Express 5.0 first and brought it up to SP3.

I don’t know if it’s SQL, Comodo, Windows, or the phase of the moon. I’m pretty frustrated. I installed the trial version on my W2003 SMB just fine, then purchased some licenses for a client and I’m looking pretty stoopid right now.

I welcome any suggestions! I’m not going to sit here watching this thread for answers but I will peek in every once in a while to see if I got any bites. Thanks!

  1. Check if latest updates installed.
  2. Check if Crypt service is running.
  3. Let us know exact OS Edition.
  4. Let us know what is the roles this server is.
  5. Attach application and system logs.

We are investigating this problem.

Thanks for the response ratz. I keep the servers up to date as much as possible. The Crypt is running. I have a couple days off and the way things work around here that’s like a vacation for me! I will gather the other info ASAP which translates into probably tomorrow night. Father’s Day tomorrow. I’m going to do the American past time thing - got to a baseball game, eat hot dogs and drink ■■■■!

Here are the requested stats on the server:
Windows Server 2008 Enterprise SP2 64bit
All updates installed
Roles: DNS, DHCP, File, Print, Terminal Services, Hyper V, AD, Remote Access, Applications, Web

Confirmed Cryptographic is running

Attached are the requested logs. I have not attempted to install ESM for a few days and did not edit the logs.

[attachment deleted by admin]

Based on provided log, you have problem Error 1920. Service ‘Comodo ESM Server’ (CesmService) failed to start. Verify that you have sufficient privileges to start system services.

The installation of CESM on any Windows computer requires Local Administrator or Domain Administrator rights to the computer. Membership in other groups may cause restrictions on the Domain Administrator account’s local rights. Verify that no restrictions on the Local Administrator or Domain Administrator accounts have been made.

Checking permissions within the registry

WARNING: We strongly recommend that you back up the system registry before making any changes. Incorrect changes to the registry could result in permanent data loss or corrupted files. Modify only the keys specified.

To edit the registry
Click Start, and then click Run.
Type regedt32.exe in the Run box, and then click OK.
Navigate to the following subkeys:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Paths

For each of these keys, ensure that both System and Administrators have Full Control.

To check the rights on registry keys in regedt32
Select the desired key.
From the menu bar, click Security, and then click Permissions.
If the Administrator and System accounts do not have full control, add them. Ensure that Deny is not checked for any rights.
Click “Advanced.”
Click “Reset permissions on all child objects and enable propagation of inheritable permissions” (or “Replace permission entries on all child objects with entries shown here that apply to child objects”), and click OK.
Click Apply, and then click OK.
Close the Registry Editor.

Checking permissions on an NTFS drive

Use the Windows Explorer to verify that System and Administrator have “Full Control” and Users have “Read Only” permissions for the following folders (if they exist):

(drive:)\Program Files
(drive:)\Program Files\Common Files
(drive:)\Program Files\COMODO
(drive:):\ProgramData (For vista-like)
(drive:):\Documents and Settings\All Users\Application Data\Comodo (for xp-like)

To check the permissions, right-click the folder, choose Properties, and click the Security tab. Verify that both System and Administrator have Full Control.

Note: Before attempting to change permissions on directories or subdirectories, you should take ownership. NT does not change permissions on a subdirectory where ownership is incorrect, and does not report that it cannot change the permissions. Using an Administrative logon is suggested.

Checking DCOM settings

The last place to check rights on a computer is in its DCOM settings.

To verify Distributed COM properties
On the Windows taskbar, click Start > Run.
Type the following, and then click OK:


Do one of the following, depending on your operating system:
In Windows XP/2003, click Component Services > Computers > My Computer. Then right-click My Computer and click Properties.
In all other versions of Windows, go on to the next step.
On the Default Security or Default COM Security tab, under Default Access Permissions, click Edit Default.
Verify that Administrators, Interactive, and System accounts are set to Allow Access, and then click OK.
Under Default Launch Permissions, click Edit Default.
Verify that the Administrators, Interactive, and System accounts are set to Allow Launch, and click OK.
Do one of the following, depending on your operating system:
In Windows 2003, skip the two following steps.
In all other versions of Windows, go on to the next step.
In the Default Configuration Permissions section, click Edit Default.
In the Registry Key Permissions window, verify that the following are set to Full Control, and then click OK:


On the Default Properties tab, verify that Default Impersonation Level is set to Identify.
Click Apply, and then click OK.
Restart the computer for the changes to take effect.

You can use Microsoft’s SubInACL utility to change registry and NTFS permissions. This information is provided for your convenience. Comodo does not provide support for or assistance with Microsoft products.

Answer recieved and ackowledged. Thank you ratz. I will dive into this within the next couple of days as possible.

same here, i try to set it up on Server2003 SP2 in VirtualBox. Someone maybe know if its working in VirtualBox??? Its a fresh install of Server2k3. tried everything adviced above, with no results.


Works for me on Windows 2003 SP2 x86 with latest updates installed and Virtual Box 3.1.2.

May be send us *.vdi file, as option?

Hi ratz,
thanks for the quick answer. got it up and running. service “Comodo ESM Server” is starting when i let the service “Log on as” with the local admin account. as “local service” not. the same is for the “Comodo Offline Updater Service”.
Comodo IntSec Service Helper and live PCSupport just starts fine with local service.

Will check all the points again and will update here.

if i will not find the solution, would be great to send u the .vdi. even when it seem to work right now. just dont like when tings are not doing what they should.


During testing I experienced problem during installation CESM 1.51 - Service failed to start.
The issue was resolved by installing .Net 2.0 SP2.

Need to check this. I just will need 2 weeks. LOL going on vacation today ;D ! I will update then if it worked for me.


.net 2.0 sp2 already installed. service starts only as admin :frowning:

Seems the system has some limitation.
If it works as administrator account, it should be a workaround.

So create new account for the service and run it under that account.