cannot download any free products

I had previously had System Cleaner working on my PC. I tried to update this software and received error that could not connect to the server. I removed the software and went to your main site to refresh this product to the most recent version. No matter what I have tired, I cannot download anything from your site that begins with "… . I have tried all the free products. I have turned off all my security software, Avira, etc. I am running on a Dell, Windows XP SP3. I cannot even “ping” the site that is provided via the automatic links. I even tried to shorten the link to the first level, and could not connect to anything.


the link works fine here ???
here’s the CSC download link

I have turned off all my security software

Are you sure?
Don’t you have an ads or script monitoring plugin (e.g. adblock or similar) denying “”?

Open your hosts file (hidden), edit with notepad: if such an entry, delete it or comment it (# before).


I, too, cannot download from the Comodo website. This is true for CTM, Update Anti-Virus or indeed any Comodo product.

I use Comodo Internet Security for my firewall, AV, Defense+Security. I get the same error message as jmc0904.

How many other users (both existing and potential) are being put off with these error messages?

Any further ideas?

Screenshots will be a nice start. What are these errors? I downloaded CIS 4 from the official web site yesterday fine.

I also have this problem. I get Error 106 whatever that is!

Hi guys,

can you please post the download link here so we can see what server is causing the errors ?

best regards,