Cannot disable antivirus from systray icon. Dialog box disappears.

I am right clicking on the system tray icon for Comodo, clicking antivirus, then choosing disable.

Comodo’s dialog box to choose the amount of time to disable AV, but then disappears within a second with that windows 10 notification sound, and i cannot disable firewall either.

Any help would be appreciated on how to fix this problem.

Windows 10.


same problem for me… windows 10 anniversary update

I am still on 1511. that update would show 1607, so it is a good idea, but that is not my particular cause.
I blocked aniversary update just now using wushowhide.

Thank you. I will investigate.

EDIT: 8/10/2016
The link you provided fixed my problem. Thank you for leading me to this solution.
The solution below from bdndc’s post fixed the issue for me. I disabled “Play sound when an alert is shown” in Comodo, and rebooted Windows 10.

Edit: 2/16/2017

  • Problem started occurring again. I enabled the “Play sound when an alert is shown” feature in Comodo. I ran an update to my sound card driver which first uninstalled my sound driver and required a reboot.
  • After reboot, alerts started working properly at this time and a sound played with Comodo alerts in Win10 notification tray (even with driver uninstalled, win10 must have loaded a driver.)
  • Next, installed updated sound card driver (update reported to fix issue with Win10 anniversary update) (old driver and alert issue worked fine for quite a while with anniversary update installed). rebooted.
  • Comodo is now working properly again with “Play sound when an alert is shown” enabled.
  • It either needed that setting checked with a reboot or the sound driver had something to do with it, but I don’t know because I did it all at the same time. A reboot may be be critical on this issue with enabling or disabling that “Play sound when an alert is shown” feature.