Can you please DON'T REBOOT by default after update?

Today i’ve lost hour of work because of Comodo updater. I’ve typed text in big complex CorelDraw drawing from paper, and was concentrated on papers, not on screen. Comodo updater question popped same second when i’ve pressed Enter to make new paragraph and guess what was happened next?

Correct - system started to reboot. I’ve tried to click “cancel” in Corel dialog to cancel program closing, but it was just ignored and Corel was forced to exit instead of cancel or delay system reboot routine. Just one key and i’ve lost my work. I kindly ask you - WHY you offering 30 minutes and 4 hours delay as options and then STEALING FOCUS AND DOING REBOOT DEFAULT with single key?

PLEASE make DELAY DEFAULT just to save your users from such issues.

Agreed. Update or Post update dialog should not steal focus.
Sorry for the inconvenience.

Thank you for answer. Can i hope that will be fixed in reasonable time?

Yes, in next major release.

On a minor but very important side note. Why is your CorelDraw not set to save every minute to prevent these things from happening? Suppose you suffer from sudden power loss. You will hours of work.

One of the first things I do when f.e. installing a word processing application is to set automatically save every minute.

Eric, you’re right, but… in case you drawing simple business cards etc.

i’m workin’ with CorelDraw since 1995 and last years my files very complex and large in common, so frequent autosave became pure pain and slows down work.
In combination with stable system and 1200VA UPS it allows me to completely disable autosave feature and press Ctrl+S when i really need it.

Respect, you’re very well prepared when using a UPS in case of sudden power loss. :-TU 8)

Now added in