Can not use MS IME in contained program [M2422]

OS: Windows 10 LTSC 2019 (version 1809)
CIS Version: 12.0.0.6870

I have added some Auto-Containment rules so that certain applications always “Run Virtually”. This has been working properly until security update KB4512578 was pushed to the PC yesterday. The symptom is, for all applications “Run Virtually”, I can no longer use Windows IME. The system tray icon of the IME becomes a grey cross, and says “IME is disabled” (see screenshot attached). For normal applications not running in Comodo containment, the Windows IME works just fine (see screenshot attached). BTW, It’s Windows built-in IME, not 3rd party IME.

If I manually uninstall KB4512578, problem is gone. After reinstalling KB4512578, the issue reoccurs. Since it’s a security update, I’d prefer to keep it installed.

Sounds like a compatibility issue? CIS update needed to fix this? Any ideas?

Hi sockscap,

Thanks for reporting. Our developers are working on the issue.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, since it occurs, all the time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Run program in container(Run virtual).
2:Try input non-English(eg. Chinese) char via MS PinYin IME , turns out it only input letters/alphabet .
3:Switch input methods, taskbar turned out “IME disabled” few sec later.
One or two sentences explaining what actually happened:
Only letters/alphabet can be input into contained program. Can not use IME input any eg. chinese beside alphabet.
No problem when run unlimited/directly. No problems weeks ago.
One or two sentences explaining what you expected to happen:
Able to use MS IME input non-alphabet characters into contained programs.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
I tried let ctfmon and chsIME.exe run via auto-containment as well. No luck.
Any software except CIS/OS involved? If so - name, & exact version:
Every process via containment, no exception.
Any other information, eg your guess at the cause, how you tried to fix it etc:
No idea. Happened recently

B. YOUR SETUP
Exact CIS version & configuration:
Firewall 12.0.0.6882
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS(safe),containment,Firewall(safe)
Have you made any other changes to the default config? (egs here.):
Nope, remove all set, uninstall, reinstall, issue still occur.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
N

Have you imported a config from a previous version of CIS:
N.

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win10 x64 PRO 1809, default UAC, admin
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
N

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)

Thanks Mathi.
I add the IME related settings I can recall in the attachment. Hopefully this can help you repro the issue.
With the settings per screenshots, the default IME is still English so it should not cause any trouble. In case you wonder how to switch different IMEs, use CTRL+SPACE.

Hi Sockcap,

Thanks for sharing the additional information.

I’ve tested it on latest v12.1.0.6914. The issue persists.

FYI. In my opinion, the issue should be related with the design change introduced since KB4512578, which only affects IMEs include Chinese Simplified (ChsIME.EXE) and Chinese Traditional (ChtIME.EXE) with Changjie/Quick keyboard. Check the following for more details.

Although I’m using Windows 10 LTSC 2019 (version 1809), the issue should affect 1903 as well.
https://docs.microsoft.com/en-us/windows/release-information/resolved-issues-windows-10-1903#336msgdesc

Can someone from developer team confirm that you can repro the issue at your side? I don’t mean to push but I hope it’s not being ignored. Thanks!

Hi sockscap,

Thanks for your patience,we will check on this.

Thanks,
PD

Fixed in 12.2.0.6938 beta 1