Can not safely remove any removable drive

Can’t safely remove any removable drive
It started after installing CAV on my machine , i just can’t get that functionality to work anymore.

The bug/issue

  1. What you did:
    I did what I do with any flash drive when I’m done with it , I tried to safely remove it from my computer , using the default way
  2. What actually happened or you actually saw:
    A dialog message telling me that there is a program is still accessing the drive!
  3. What you expected to happen or see:
    I was expecting to be able to safely remove the drive without any problems !!!
  4. How you tried to fix it & what happened:
    well, I didn’t blame CAV in the first place so I tried unlocker.exe to see if there is any handles that I can unlock so that i can safely remove the drive , but there wasn’t , besides , I tried disabling CAV , D+ and FW with no success at all !!
  5. If its an application compatibility problem have you tried the application fixes here?:
  6. Details (exact version) of any application involved with download link:
    has nothing to do with anything else other than CAV
  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    insert your flash drive and do your normal job with it , opening documents , copying or pasting , and when you are done , try to safely remove it! you will see the error.
  8. Any other information (eg your guess regarding the cause, with reasons):
    the reason is CAV because when I uninstalled it , the issue was gone with it

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
    stock settings
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used:
    stock settings
  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    I did change some settings regarding D+ but it has nothing to do with it , since I did confirm that the major factor of this issue or let’s say " the problematic one " is CAV
  5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =
    safe mode , on , safe mode & stateful
  6. OS version, service pack, number of bits, UAC setting, & account type:
    windows xp , sp3 , 32bit , Administrator
  7. Other security and utility software installed:
  8. Virtual machine used (Please do NOT use Virtual box):
    No, it was on my real machine

I hope that this bug gets fixed quickly , so that I can reinstall CAV

thanks in advance


Thank you for your bug report in the required format.

I believe there has been a report before not sure, will see if I can fine it.

No problems on my partner’s computer only difference is XP Pro and Full CIS Sandbox disabled though.


I’ve reinstalled CIS now , I’ll try it again and again till I know exactly why it happened then !

** update **

it seems that the issue is gone with the latest installer, I can’t reproduce the same issue again

Thanks for trying a reinstall :slight_smile:

This sometimes works, it really could have been anything, a bad install etc.

Thanks for posting back


Moving to resolved.

Please post here if the problems happens again.

Thank you