Can not open CIS on new computer

I have installed CIS on my new computer and can not open it, CIS is in the task bar, the widget works and I was able to update from the widget, however when I try to open CIS nothing happens exept a quick loading ring on the cursor for a fraction of a second.

CIS worked fine for years on my old computer.

This is my computer specs

Operating System: Windows 7 Ultimate 64Bit
Motherboard: Asus H81M-K mATX
PSU: Corsair CXM 430W
Processor: Intel Core i3 4160 3.60GHz
RAM: Corsair Vengeance 8GB (2x4GB) DDR3 1600Mhz
Graphics card: Asus GT 610 Silent 2GB DDR3
Main Harddive: Sandisk Plus 240GB SATAIII 2.5inch SSD
Secondary Harddrives: WD Green 3TB 3.5" SATA, WD 3TB 3.5" SATA

Many thanks

So does CIS need anything else like a particular .NET Framework or somthing?
CIS is running, it’s in the task bar and I still cannot open the program.

No it does not need anything.

As it is a new computer are you sure you remove all of the preinstalled security software.


Just finished upgrading my system with a new board and now CIS refuses to open the main screen as well. I now have Win 7 on Asus B150M w/Core i5.

I removed according to instructions here (Comodo Forum) and re-installed Oddly when I check the CisDump folder I get recent dmp files for:


I got the 4792 from the announcement thread here ( so I guess I was expecting the crashing programs to have the same version # so i’m totally confused now.

Edit: Found this is the Windows logs:

“Event provider attempted to register query “SELECT * FROM CisStatusChange” whose target class “CisStatusChange” in //./root/cis namespace does not exist. The query will be ignored.”

For the benefit of others i’ll share how I got this going, albeit not with the CIS 8.2.

Did about as clean an install as I could with an existing Win 7 installation that was recently swapped to a new motherboard.
0) Originally had CIS on my original motherboard

  1. Removed Comodo using Control Panel->Programs & features->Uninstall
  2. Rebooted to Safe Mode
  3. Used script by Chiron & “COMODO Removal Tool 2014 - Mods Version”
  4. Followed steps by user Rigo (Post #117) here: (Registry Cleaner used was CC Cleaner).
  5. Rebooted and re-checked that Comodo appears to be removed.
  6. Re-Installed latest… and … no joy. CIS and cmdagent continue crashing exactly as posted above with the same version numbers.
  7. Frustrated, downloaded this ( as mentioned in this post (
    8 ) Simply ran it on top of what was there… and … whoa… it works. Shows Version 7.0.317799.4142.
  8. Did virus update. Good. Scan. Good.
  9. Did Software Update… downloading … installing … BOOM!
  10. So, uninstalled using Windows. Rebooted.
  11. And re-installed 7.0.317799.4142.
  12. Now i’m calling it a day.

Now you’re talking. I ran into problems such as you mentioned (see my signature). I’ve been running v7.0 and am very happy.