Can anyone make "Age of Empires III" work with Comodo 3 (free version)?

When I’m going to connect with another PC inside the same LAN, there is no any visable game list (seems like we can’t see each other). The other PC is using windows default Firewall. Before I installed Comodo 3, everything is OK.

  • No matter my host works as client or server.
  • No response when using “Direct IP”.

Steps:
1 I tried delete all rules associated with the game and place both Firewall and Defence+ into “training mode”. It doesn’t work.
2 I tried place both Firewall and Defence+ into “Disabled”. It doesn’t work. Also exit Comodo doesn’t make sense too.
3 Finally I uninstalled Comodo, everything becomes ok even without restart PC.
4 I tried it again with a fresh install today and place into “Training mode” at the first, it is the same with what I encountered yesterday.

Is there any solution or workaround? Personally I do like Comodo very much, but I can’t afford uninstalling software everytime when I’m gaming. I can’t understand when I disabled Comodo, why it is still working in the background. This is a very anoying behavior. I found a Comodo service in background but not able to disable it.

Can anybody give some advice? Thanks very much in advance!

Going to Training Mode is a good step. But that is not helping when you need an open port for incoming traffic; that requires rule(s) in Global Rules. Does this game need one or more open ports for incoming traffic? If so, which ports?

Thanks a lot for your hints!

BTW, from the active connection, I can see age3 are sending traffics out, but with zero input traffics. I also followed some instruction in https://forums.comodo.com/empty-t41013.0.html, but still doesn’t work.

1 Regarding the ports used by Age 3, according to the two URLs below, they are 2300~2310:

TCP Ports: 2300-2310
UDP Ports: 2300-2310

2 I’m very interested to find a way to completely disable Comodo at some time. Now it can only be disabled in literary, but still takes effect unless I uninstall it. This (fully disabling Firewall as if it is not installed) can be very useful in future’s debugging if I found some applications don’t work properly.You know, it is boring to uninstall/install it if I hesitate something is messed up by the Firewall. Is there such a method? ;D

It is time to open the ports for incoming traffic.

Do the following:
Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCPor UDP
Direction: In
Description: Incoming Ports AoE 3

Source address: Any
Destination Address: Choose MAC address, Single IP address (only when it is fixed) or Host Name
Source Port: Any
Destination Port: A port range: 2300-2310

Then push Apply. Now look at the Global Rules and make sure the new rule is somewhere above the basic block rule(s), with the red icon(s), at the bottom. When needed drag and drop the rule to its proper place.

Now delete the rules for AoE in D+ and Firewall, put both in Training mode and try again.

Thanks a lot for help! I will try it later.

Keep us posted.

Sorry for such a late update. I tried it again today, with a fresh reinstallation.

1 The good news is that “disabled” mode can allow us playing (unlike last time). It’s pretty good workaround to me. Though disabling Firewall during gaming time means somewhat dangerous, I think it is acceptable since I’m behind a NAT.

2 The bad news is, adding a global rule doesn’t solve the problem. (1) I further modified the global rule to be (Allow, TCP or UDP, In/Out, Any src/dest ip/port), but still can’t connect it with each other. (2) From Firewall events, I can see the incoming packets from the other PC. But I never see they are communicated with each other, and never see AOE3 leaned an income rule (even after manually modify it to be input/output).

Topology:
My PC (192.168.1.102, Comodo Firewall) <—> The other PC (192.168.1.103, Windows Firewall), both have Vista OS.

Firewall Events:
Allowed: 192.168.1.103 (port: randomly from 50281 ~ 62303 ) → 255.255.255.255 (2299)
Allowed: 192.168.1.102 (port: randomly from 50281 ~ 62303 ) → 255.255.255.255 (2299)

3 Though it’s possible to further debug it (e.g. using Wireshark to capture some packets), I feel somewhat tired and pretty satisfied with currrent workaround (temperarily disable Firewall). Thank you very much for previous help!

You edited the global rules to allow tarffic on all destination and source ports. That is the same as disabling your firewall. All ports are now open. That is not recommended of course. Please stick to the rule I provided.

Is there other traffic being reported in the Firewall logs then what you provided? Please post a screenshot of around the time you are starting the program.

One thing to try is to make your local network a trusted network. Here is the drill:

First look up your IP address and subnet mask. In Windows go to Start → Run → cmd → enter → ipconfig → enter → now lookup your IP address and subnet mask.

Second create a zone in My Network Zones (Firewall → Common Tasks). Choose Add → A New Network Zone → fill in a name like My local network → Apply. Now select My Local Network Zone → Add → A new address → choose An IP Address Mask → fill in your local IP 192.168.1.102 and your subnet mask; 255.255.255.0 → Apply. Now check and see the new network defined. Exit using Apply.

Now we are going to use the Stealth Ports Wizard to make your local network a trusted network (Firewall → Common Tasks):
Choose “Define a new trusted network and stealth my ports to EVERYONE else” → Next → choose “I would like to trust an existing My Network Zone” → choose your local network zone from the drop down box at the bottom → Finish.

Now check your Global Rules and see your network added.

I managed to finally get AOE3 working with Comodo 4 by going to Firewall->Advanced->Firewall Behavior Settings, going to the advanced tab, and unchecking Block Fragmented IP Datagrams. That’s the ONLY way I got anywhere with it. Hope this helps others, it took me hours of googling/forum reading/messing around.

Thanks for the information blahblahblah6669.