Callwave Internet Answering Machine

Hi, I just started using comodo yesterday, and am still learning.
My current problem that is my Callwave Internet Answering Machine now doesn’t pop up immediately when a phone call comes through, plus the incoming call ring/alert doesn’t sound either. I did enable callwave in comodo, so am not sure what the problem is. Any help would be greatly appreciated.
Take care,

Hi and welcome,

Can you provide some details of your system (os, software, etc.), as this may help find any problem.


I have Windows XP SP2.
I ran zonealarm before comodo.
AVG anti-virus.
Microsoft Defender.
Spybot S&D Resident Shield.
Let me know if you need any other info.
Thanks in advance.

  • Jamie

Ok, thanks. Have you tried disabling comodo firewall, then trying the software and see if the problem persists or not?


I just tried it. It worked. Something in Comodo is preventing it from immediately popping up, and ringing the call alert. Thanks.
P.S. I do like comodo.

How did you enable Comodo for Callwave? Did you add the rule manually / automatically when Comodo asked you?

If manually can you tell us what you put for the rule?


I selected allow when comodo asked me.

Ok, can you find the rule for this in ‘application monitor’, select the rule and choose ‘edit’. Check ‘allow all activities for this application’ and then check ‘skip advanced security checks’ and ‘allow invisible connection attempts’.

It may be that these checks Comodo does are slowing down the application which is why it doesn’t popup immediatley. But, as to why you have lost sound I am unsure.


That seemed to work, thanks.
I discovered something else: the google gmail notifier window isn’t popping up anymore.

  • Jamie

OK, glad that worked.

Have you tried doing the same with Gmail and verifying Gmail’s settings also?


Seems like gmail notifier is working now, but it seems like Callwave IAM is now doing the same thing again.

Can you open Comodo firewall, go to ‘security’>>‘advanced’>>click ‘configure’ under the miscellaneous section>>check ‘Skip loopback (127.x.x.x) TCP connections’.>>reboot>>and then try again.


OK. Thanks. I did that. looks like it is working.
Thanks again.

  • Jamie

Ok, that’s great. :wink: I’ve marked the topic as ‘resolved’ and locked it. If you find the problems appear again, just PM me and I’ll open the topic again.


Hi, Just wanted to let you know that the problem with the Callwave Internet Answering Machine has resumed. The call alert doesn't pop-up until about 15 seconds after the call. There is also no ring alert sounding. I turned off comodo, and it works fine. Thanks in advance.


Thanks for the PM. I’ve opened the topic again.


Hi jamiesandhillcrane,
Can you please clear logs and try to use Callwave and see if there are any entries under logs, if you find, please paste them here.

I also use Callwave and had a similar problem at first. My wife said that people were telling her that they got busy signals instead of the usual callwave greeting. I called the home phone several times from a cell phone and some connected, others didn’t. I noticed in the activity log that each time a call didn’t go through to callwave, UDP incoming access was denied to port 9283 at the exact time of the call. I googled port 9283 and apparently it is assigned to IAM. In addition to allowing all activities for IAM in the application monitor, I setup a new rule : ALLOW UDP in from any to any where source port is any and Destination port is 9283. I haven’t had any problems since. I hope this helps.

There are some good suggestions here from Frank at Comodo support which may help you and others solve this problem:

  1. Can you increase alert frequency to high / very high and turn off allow apps approved by Comodo. Sometimes although you may have allowed part of an application executable the application uses another executable which an alert is not displayed for. Changing these settings will allow an alert to be created if needed.

  2. You may need a new network rule. It may help if you go to Callwave’s website and/or ask them about setting up a rule for a firewall. See kstev99 post also.

  3. Try finding AVG in the application monitor and editing to ‘skip advanced security checks’. AVG may scan Callwave as it opens up and CPF may try to check both AVG and Callwave at the same time and causing interference as the scanner needs full access to scan.

With thanks to Frank at Comodo support.


I emailed callwave tech support about setting up callwave with firewalls 2 weeks ago, when I first installed COMODO and their reply only told me that callwave needed call forwarding on busy from the phone company (which I already knew). After setting up the new rule myself, I found this information on their website:

If you’re setting up a firewall yourself, you’ll need to allow two types of connections:

  1. Port 80/tcp and 443/tcp for outbound connections to CallWave servers. (These ports are usually already open for basic web browsing.)

2a. [Stateless firewalls]: Port 9283/udp inbound and outbound.

2b. [Stateful firewalls]: Port 9283/udp outbound. The firewall’s stateful timer needs to be greater than 2 minutes. If you have a stateful firewall that has a shorter timer that can’t be tuned, use the stateless approach above.

Do not bother configuring a firewall with knowledge of CallWave’s IP addresses. These addresses change too often.

This can be found at:

I wonder though, I only set up to allow UDP in on port 9283 and it seems to be working ok. I wonder if I should allow UDP in and out, and whether leaving this port open makes me vulnerable to any attacks?

Yeah, I wouldn’t really want an In rule like that just sitting there; it’d make me nervous, especially since you can’t define an IP for it (per Callwave’s note).

I don’t use Callwave, so I’m kind of taking a stab in the dark, but if you have software on your machine for Callwave, you might give this a shot…

Try changing that In rule on port 9283 to an Out (so that you don’t have an In rule on that port at all). Make sure you set it to “create an alert if this rule is fired.” Reboot your computer.

Then make your test calls again, and see what you get in your logs. It might not work at all that way, but I’m wondering if Callwave software isn’t perhaps monitoring for some sort of alert that only it sees, in order to open the port. Thus, the Out rule would work, since with CPF, an Inbound connection doesn’t need to have a rule if it’s in response to an Outbound request (thus when you’re surfing you only need an Out rule; no In rule is needed to download a website, etc).