Cache Cleaner runs endlessly

As the title says I have noticed the cache cleaner is running for hours at a time and only stops when I manually stop it from the CIS task manager. This is a relatively new development I would say I have only seen this behavior for the last week or so.
I haven’t noticed when it starts , I would expect it to restart after an AV database update, I have my updates at the default 6 hours but I’m pretty sure it’s happening more often than this,I will keep an eye on this.
I have also noticed the cache cleaner is quite heavy on my resources as I said I will monitor this further and add more detail as I see it

I believe there may already be a bug report created for this behavior. Please check through the bug reports and see if there are any which match what you are seeing.

It’s not supposed to run for hours on end, and even when running should be a background task such that it is using very few resources. If it is running that long, and using a lot of resources the whole time, I do think that this is a bug which would be worth reporting.

i havent experienced this myself.i notice it runs after an update but i believe you can set this somewhere.
What exactly is it doing.?

I believe so also I will check.

I can’t answer this as I don’t exactly know but from what I gather this is part of optimizing the scanning process where the same file is only scanned again when it has been altered.

I have recently disabled the TVL, this may be something to do with it…
I will re-enable the TVL and see if this resolves matters if not I will create a formal bug as I can only find a non formal report.

I am experiencing the same issue, cache cleaner runs endlessly and takes a lot of resources, is there a fix for this ?

Any solution will be good.

I just started experiencing this issue. Cache cleaner was running for an hour, cavwp.exe is eating up about 60-70% CPU. I tried to terminate the cache cleaner in the CIS task manager, but it ends up stuck on “Terminating”. Then Windows shut down my browser for using too much memory, and then crashed afterward. I restarted, and cache cleaner was back to running in the background, and cavwp.exe is eating up the same CPU as before.

I restarted again and tried to terminate ASAP. It’s been stuck trying to terminate for the last ten minutes, but cavwp.exe is back in a normal CPU range (0-10%).

I have Malwarebytes. Would that suffice as an AV? Windows Action Center doesn’t want to recognize it as an AV program, so it warns me when I turn Comodo AV off. If I wanted to uninstall Comodo AV, would I have to uninstall the firewall too and reinstall just that, or is there an easier way to just uninstall the AV component? The cache cleaner seems to be running even when I uncheck the checkbox for realtime scanning.

Opening the Task Manager in CIS shows Cache Cleaner, still “Terminating”, over 18 hours on the timer. There’s a second line now.

Virus Scan - C:\Pro…

The thing is, now I can’t close the Task Manager. Clicking on anything in that window does nothing. Killswitch>cis.exe>Kill Process fixes that by getting rid of the frozen window, but now the problem has another layer added on to it. No excessive CPU consumption ATM. Also, it’s hard to tell because of the window freezing, but I think that scan might be stuck as well.

Is there an easy way to get rid of CAV without uninstalling CIS in general? And would Malwarebytes suffice as a computer’s only AV?

Is this problem solved?? It’s so anoying… :o