Cache Builder doesn't stop when computer is no longer idle.

2. The full product and its version e.g. COMOOD Firewall 7.0.308911.4080

COMODO Internet Security Premium 7.0.308911.4080 BETA

3. Your Operating System (32 or 64 bit) and Service Pack revision. and if using a virtual machine, which one.

Windows 8.1 64bit. (real system)

4. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?

Too many to mention, will attach a config file.

5. Did you install over a previous version without uninstalling first, or import a previous configuration file? (please try to avoid doing these things until we are told it is safe)

No, and no. Clean install and new configuration file.

6. Other Security, Sandboxing or Utility Software Installed

OpenDNSCrypt | Zemana AntiLogger Free

7. Step by step description to reproduce the issue

Basically don’t use your computer for a while so the Cache Builder starts, when it has started then start using your computer again, this should stop the Cache Builder but it doesn’t.

8. What actually happened when you carried out these steps

The Cache Builder kept running even when my computer was no longer idle, I even started a game and played for a bit but the Cache Builder didn’t stop, it kept running.

9. What you expected to see or happen when you carried out these steps, and why (if not obvious)

I expected the Cache Builder to stop as soon as I started using my computer again, if not that then at least when I start a GAME!

[attachment deleted by admin]

Thank you for submitting this report. Please attach a KillSwitch Process List to your first post. If possible create this when the cache builder is running when it shouldn’t be. It’s possible that this is caused by a conflict with another process.

Also, please specify how often you are experiencing this problem. From what you’ve seen does the cache builder every stop on its own?


I’ll wait for the issue to appear again, it appears this might be an intermittent issue since I just got back to my computer after it being idle and the cache builder now stopped when I moved my mouse. When it happens again I will attach the KillSwitch process list to the first post.

I don’t really let my computer go idle that often but since I installed CIS 7 beta I’ve noticed it at least 3-4 times. Once it stopped on its own, but maybe an hour or two after the computer no longer being idle.

Actually, as it’s so intermittent, it’s probably safest to create a Full Dump and put a download link for it in your post. That way the devs should be able to fully see what’s going on. Would that be possible?


When (if) it happens again I will make a full dump, I will try to force the cache builder to run at some point, just wondering for how long the computer has to be idle before the cache builder starts?

Hi Sanya,
I presume the default setting is idle for 5 minutes, that is what mine is set at and I have not altered it (Screenshot).
This can be viewed in 'Windows Task Scheduler, double click the mentioned task in the Comodo folder and look under the conditions tab.

Kind regards.

[attachment deleted by admin]

I might as well ask, what defines idle? No input for x minutes and then 5 minutes on top of that?

Does the following external link help?
Task Idle Conditions-Microsoft

Indeed it does, thanks, I’ll try to get my computer into idle mode.

Edit: Whelp, I left my computer untouched for about 40 minutes… still the cache builder never started…

Have you been able to replicate this issue?

I haven’t even been able to get the cache builder to run. :embarassed:

That’s strange. I suppose that for the time being I will move this report to the non-format section. If you are able to reproduce the problem try to get the full dump through KillSwitch. Then respond to this report. Without that I believe that an incredibly intermittent bug like this will not be able to be fixed.


Okay I’m 90% sure the cache builder or at least its scheduled task is completely broken for me, I’ve left my computer idle for 1 hour maybe 6 times (i.e 6 different times) and the Cache builder didn’t start any of those times, so I decided to edit the scheduled task and I disabled the settings that would stop it from running once you exit idle and then I right-clicked it and clicked Run… This should in theory start the cache builder since there’s nothing that tells it to stop, but still nothing happened… No cache builder…

Whelp ???

Now I’m 99% sure that CIS is incapable of starting the cache builder on my machine anymore, the reason being that if I open CMD and navigate to CIS installation folder and type:

cfpconfg.exe --launchSchedule {B9D5C6F9-17D2-4917-8BD0-614BAA1C6A59}

Then it will start the signature updater, but if I type:

cfpconfg.exe --launchSchedule {0FB77674-7905-4F34-A362-C5A9A26F8CF9}

Then the cache builder doesn’t start… I think it’s just ■■■■■ for some reason… which is interesting since it worked before and nothing has really changed since then…

For the purpose of the full dump I’ll restore a snapshot of when I first installed CIS and see if I can get it working again, but it’s getting late so it’ll probably happen tomorrow.

I restored the snapshot of when the cache builder worked and I’m now 100% sure that this issue with it not stopping is because of some configurations for the HIPS I did, essentially I changed the HIPS rules for Comodo Internet Security so that other programs other than Comodo Programs can’t kill it’s processes, the issue is that when task scheduler ends the task when computer exits idle it basically just terminated cfpconfg.exe which was then because of the HIPS rules not allowed.

This thread can be moved to Resolved area.

Still can’t get cache builder to run in my most recent snapshot. ??? I’ll probably attempt a clean re-install later and see if that fixes it.

Okay update time, I found the reason why the Cache Builder refused to start, I remember that I stopped a malfunctioning Full Scan before (Got stuck on a file on the HDD and the HDD make a sound as if it was going to ■■■■) it was after that the Cache Builder stopped working I think, basically I solved that by doing another full scan and now the task starts normally.

Regarding the issue that the task scheduler wasn’t able to stop the Cache Builder, well I added the necessary files to the exclusions for Process Termination in the HIPS rules but still it for some reason wasn’t allowed to kill cfpconfg.exe until logs were deleted (what the fuck?!) But now it seems that the task scheduler is allowed to start and stop the task… which is good… so yeah, can be moved to resolved.

Okay. Thanks for looking into this so deeply. In that case I’ll move this to Resolved.

If it does turn out that there is a bug present please send me a PM, and respond to this topic, and I can move it back for processing.