C.I.S not showing

I have just installed the latest C.I.S in Windows 7, and it doesn’t show up in the add/remove section in case of needing an un-install. I also can’t find an uninstall file in the comodo folder. Can some-one give me so help as to how to uninstall C.I.S from Windows 7 in case I need to do so.

Usually there is an uninstall shortcut in the Start Menu under Programs. I think running the installer would work as well.

I’ve just had a very similar problem with an installation onto XP Pro SP3: the beginning of the installation started fine, and when it got to the Scan entire computer for malware I knew it would take all night, so I went to bed. About sunrise I heard my computer reboot, and when I later sat down at the computer I found that Windows was running fine; but no Net. Then I discovered: no system tray icon, no icon in the Start menu, and no record of CIS in Add/Remove files! Also, it didn’t install into the folder I told it to, but directly below Program Files. The Task Manager said it was running, but I had no access to it. I have no way of uninstalling it because there is no link to any uninstall file! Clearly the program had a problem during the night and I wasn’t there to answer a dialog (I presume) so it went ahead anyway, and the installation somehow failed. For some reason I doubled clicked on cfp.exe. It gave an error dialog but very usefully asked if I wanted to run diagnostics. Diagnostics reported that there was a problem with the installation and it couldn’t fix it, so I saved the report. I rebooted and it was still bad, so I rebooted again. Suddenly the system tray icon appeared and I was able to launch the interface (but still no icons on the desktop or Start menu, & Comodo is still not listed in Add/Remove programs. Diagnostics still reports an unfixable problem.
So it sounds like my problem is very similar to Nugar’s. :-[

Dice could you try System Restore to see if that is of help?

Thanks EricJH; but I’ve had some bad experiences with System Restore in the past and would rather not go that far unless I really have to. I read on one of the threads here that if I run the following:
C:\program files\COMODO\Comodo Internet Security\cfpconfg.exe -u
it will uninstall the program, then I can try reinstalling it. What do you think?

That’s the command line, it should uninstall it.

OK, I’ll try it. Thanks.

I couldn’t get Run… to accept the command line (it said, c:\Program is not a valid path, even though I’d put in the whole line), so I tried something else: I shut down all running programs then ran the same (latest) CIS setup file again. This time I said No to doing a system malware scan. After reboot, to my great surprise, it had installed properly, showing all the icons, Start menu items etc. Yay! Thanks for your suggestions though.