Bug: Orthos Prime cannot start after last update (V3.10.102194.530 X64)

Orthos Prime is a CPU burn-in/test application. It was working fine prior to today’s (as of this post date) update.

NOTE: I’ve attached the Orthos Prime to this post.

My info:

  1. CPU: Intel C2D e8400 64-bit

  2. OS: Windows Vista 64-bit, Service Pack 2, UAC disabled.

  3. Processes: skipped…

  4. Symptoms: Orthos prime will not launch. An error message will be shown that states: “The application failed to initialize properly (0x0000018). Click OK to terminate the application.”
    Steps to reproduce: Just try to launch Orthos Prime latest version on Vista 64 with Comodo Firewall and Defence+ installed. Even with Defence+ and Firewall set to “Disabled” problem persists. Orthos Prime does NOT need an internet access, so the problem must be connected to Defence+ or its kernel.

  5. How to resolve: I’ve uninstalled Comodo Suite and tried to run Orthos - it ran without problems just like before. Then I’ve installed latest Firewall with Defence+ again and problem was reproduced once again.

  6. Firewall and Defence+ mode: I usually set Firewall to “Custom Policy Mode” and Defence+ to “Clean PC Mode.” In this case, however, no matter if I set both modes to “disabled” the problem persists.

  7. BSODs: no BSODs happened.

  8. Account: I’m using the Administrator account with UAC disabled.

  9. Additional Info: As I’ve said before, Orthos prime was always working just fine with the configuration that I have until today’s update from Comodo. It’s clearly related to Comodo firewall or Defence+ because program runs just fine after uninstall of Comodo and can’t run after re-install of the latest version.

My current (problematic) Comodo version is: 3.10.102194.530 (64-bit version, no Antivirus only Firewall/Defense+)

Please use the attached Orthos Prime application to test or download the same version from somewhere else.

Thank you!

[attachment deleted by admin]

I did some more testing and now I’m sure that the reason for this problem is the Defense+ kernel because going to D+ settings page and selecting “Permanently disable Defence+” and then rebooting also fixes the problem. Somehow D+ kernel prevents Orthos from initializing. I wonder what was changed though because it never happened before this last update. For now I’m just staying away from Defense+ as a temporary solution until it will get solved.

Try putting it to exclusions list under image execution control settings - when D+ is enabled.

Ok, just tried to put Orthos to the exclusion list of image control = still the same, program can’t initialize properly.

It seems like something inside the D+ kernel prevents Orthos from getting some system info or something similar. I wonder what exactly changed in the last update that causes it.

I’ve also tried to not permanently disable D+ but just set it’s mode to “Disabled” and still this problem persists. Also D+ doesn’t even say anything about Orthos trying to access or change something. I even tried “training mode” with no success.

Finally, I even tried to disable all “activities to monitor” in the D+ settings. I’ve unchecked all checkmarks for activities to monitor and objects to monitor. Still no go.

Hi premudriy

Please read this: https://forums.comodo.com/firewall_bugs/please_dont_post_cis_310_bugs_he_read_this_first-t42120.0.html


Oh, sorry. Apparently I can’t delete my own thread here, so if mod can remove it that’s fine. Thanks.

Try updating to the latest version that was released just a couple of hours ago.

Yes, I did already. It works now:-) Thanks. And again, I’m sorry to post here and not in the appropriate thread, so moderators can delete this if needed.

Thank you for confirming the fix!

I’ll close this thread.