[BUG] CSE does not work and can't uninstall

OS: Vista x64
Thunderbird version:
CSE version:

INTRO: I have Thunderbird working fine with my Comodo certificate on its own. I am now trying to install CSE so I can send encrypted mail to people who are not using certificates (this is what CSE can do by forwarding them to a web page to decrypt, as I understand).

  1. I have installed CSE x64. (I have tried CSE a few months ago, so it still had all of the settings and certificates from the previous installation).

During install it recognized and installed my Windows Mail (which I don’t use) profile, but it didn’t see Thunderbird - which I use - (and neither did it see Outlook - which I also don’t use).

  1. I configure the CSE smtp to use smtp.gmail.com port 465 SSL, and I try to send some email from my account A (which has a comodo certificate in Thunderbird and also in CSE) to my account B (which does not have a certificate). I also make sure to always “uncheck” the message signing in Thunderbird (as I have Thunderbird setup to always sign my messages with my certificate).

RESULT after 30 trials: CSE does nothing. Email goes always through unsigned and unencrypted. Furthermore, I have CSE sercurity state set to VERY HIGH, but the mail still goes through without any information or blocking form CSE - this is not secure at all (in such a case CSE should not allow the mail to be sent).

  1. Reading these forums, I seem to understand that the 64bit version of CSE only works with 64bit email applications (WHY wasn’t this explained to me when I downloaded it? I have vista x64 so I automatically chose x64 ??? )

So, I now install the 32bit CSE.

  1. During install, the 32bit CSE now sees and imports my Outlook settings. BUT it still does not see Thunderbird ??? (and it doesn’t see the Windows mail, which the x64 SCE did see).

  2. In 32bit CSE I now try to add smtp.gmail.com port 465. When I click “OK” I get a popup “Wrong Parameter”.

  3. So I try to change it in the x64 CSE, I also get “Wrong parameter” when clicking on “OK”

  4. So I try to uninstall CSE 32bit and 64bit. For both, on the second uninstaller page (the page where it asks if I want to keep the settings or not), when clicking on “next” I get “Wrong parameter”.

  5. RESULT: I can’t uninstall CSE (neither 32bit nor 64bit) and I can’t change the settings in any of the versions (due to “Wrong parameter” when clicking on “OK” to apply the changes).

→ I am completely stuck. What should I now do short of reformating and reinstalling Vista?

Thanks for your help.


We are looking into this issue and will respond to you soon.

Thanks for the full description of the problem.

Regards, Eugene.


We need from you some additional information to help you with the issue.

  1. What edition of Vista do you have? (Home, Enterprise, …)?
  2. Do you have any other Comodo software products installed?
  3. Do you have any other security software (firewall, antivirus, antispam, etc.) installed?
  4. Did you try running SecureEmail uninstaller using “Run as Administrator” option?
  5. Could you send us screenshots of the “Wrong parameter” dialog both when you try to change settings and uninstall?
  6. Could you export and send us the following registry keys - HKEY_LOCAL_MACHINE\Software\ComodoGroup and

We can provide assistance as to how to do the above (screenshots and exports) if you need it.

Regards, Nick
Comodo SecureEmail Developer


Thanks a lot for helping me. I hope we will get this to work properly :slight_smile:

Vista Business X64, service pack 2.

Comodo Internet Security 3.12

(I have replaced Nod32 4 with CIS 4 days ago. I am pleased with it and see that the Anti-virus part is improving fast, so I am keeping CIS. This is also the reason why I am trying the other Comodo software, and in this case I am trying CSE again - CSE didn’t work for me when I first tried it a few months ago, so today I am putting a little more effort into getting it to work.)

No. edit: Yes, Malwarebytes Anti-Malware, but it is on-demand only, so it isn’t running.

The vista firewall is disabled. I only have CIS (I have uninstalled Nod32 before installing CIS).


Also, this question reminds me of a “behavioral” problem with the CSE installer. When I fist installed it, the installer didn’t work before I launched it with “Run as Administrator”. Under vista applications are supposed to ask for this privilege automatically, so this is something (a detail) you might want to improve in a future version.

File 1: SCE_32bit_click_on_PROPERTIES_shows_this_popup.jpg

This is what happens when I click on “properties” in the 32bit version (I cannot see the settings in the 32bit version, but in the x64 version I can)

File 2: SCE_x64_click_on_OK_to_apply_shows_this_popup.jpg

In the x64 version I can see and edit the settings. But when I click on “OK” to apply them I get this popup.

File 3: SCE-uninstaller_32bit+x64-same_click_on_NEXT_shows_this_popup.jpg

The same problem happens with the 32bit and the x64 versions of the uninstaller.

BTW, as you can see there is a (minor) problem with the application translation (it is not complete). The application is in English, but the popup and the buttons in the uninstaller are in French (my vista is in French).

(French “paramètre incorrecte” = English “Wrong parameter”)

I have attached everything (the 2 reg files + the 3 jpgs are in the attached 7z archive).


edit: I didn’t have this “Wrong parameter” popup problem when SecureEmail x64 was installed alone. This problem only appeared after I added the 32bit version.

To summarize, I see 3 problems:

1. There is a conflict between the 32bit and the 64bit versions of SecureEmail.
2. The 32bit version only sees and imports 32bit email apps, and the 64bit version only works with 64bit email apps.
3. There is a problem with Thunderbird, because neither the 32bit nor the 64bit version of SecureEmail sees it (during install when importing the settings).

edit 2: since I have installed CSE 32bit I now get a popup everytime I start Thunderbird, asking me if I want it to check my emails for encrypted mails. (this leads me to think that it would probably work if the x64 version was not installed? :-La )

[attachment deleted by admin]


Unfortunately we still can’t reproduce your issue.
We are working on it now.

Actually CSE asks to change settings of found mail clients. And if your Thunderbird mail client had no SLL accounts then CSE should not have asked to change it’s settings while installation.

This pop-up - is a part of Thunderbird plug-in installed by 32bit CSE. It allows you to scan for already received e-mails encrypted with single-use (session) certificates and automatically decrypt them. Such e-mails are send by CSE to recipients that you don’t have certificates for - if you still need to send encrypted e-mail fro such recipients. You can turn off this pop-up by either selecting “don’t show this windows” check in the pop-up or by unchecking option “Prompt to scan e-mail folders next time Thunderbird starts” in CSE Options->“E-mail folders scanning” Tab.

Regards, Eugene


For now we recommend to do next actions:

1) Remove Comodo SecureEmail entries in your registry:

  • HKEY_CURRENT_USER\Software\ComodoGroup\Ports
  • HKEY_CURRENT_USER\Software\ComodoGroup\SecureEmail
    2) Uninstall x64 version
    3) Uninstall 32bit version
    3) Reboot
    4) Restore mail clients settings to the correct state (when you delete Ports key CSE is unable to restore your mail clients’ settings)
    5) Check if mail clients work OK.
    6) Install CSE 32bit
    7) Check if CSE works OK for you now

Thanks in advance.

Regards, Eugene

Thanks a lot, this procedure worked fine :-TU

I now only have SecureEmail 32bit installed and it now works with Thunderbird (when sending messages without attachments).

However, I now have another BUG when I send a message with an attachment (i.ex I tried to attach a 1.5Mb PDF file) SecureEmail hangs.

Procedure (tried 10 times):

1. When sending mail with an attached file the SecureEmail popup comes up and shows:

  • connecting to smtp sever
  • signing message … and there it hangs (I have waited for 5 minutes)

2. I then need to quit Thunderbird
3. Kill the SecureEmail process with the task manager (If I don’t quit Thunderbird before doing this, Thunderbird will crash when I kill SecureEmail).

And finally, 1 question (regarding usability issue):

Could you please add translations for the English Comodo email people receive when they don’t have a certificate (the mail that informs them of the encryption and directs them to download SecureEmail or forwards to the website)? Because as of now non-English speaking people will not understand what this is about.

For my communications I would also need French (but I am sure many other users would need Spanish, German, Italian, etc…)

→ I think the best would be to have an option to select the language in the window that pops up when the recipient doesn’t have a certificate (this is the windows where when have to chose if we want to encrypt or not); this way we could select the right language for each recipient.

(or if you won’t add translations, would it be possible for us to edit this massage so we can translate or modify it ourselves?)

Thank you.

Hi, MBK.

Great news :slight_smile:

This issue is fixed in Comodo SecureEmail 2.5 RC build (You can read about it here: https://forums.comodo.com/cse_beta_corner/comodo_secureemail_24098_rc_released-t48294.0.html)

We are going to add support for different languages in releases after CSE 2.5.

Regards, Eugene.