BSOD Windows 10 update, failure of cmdhlp.sys, update 1709 (10.0.16299.98)

I updated Windows 10 today so I could try out Dolby Access for headphones (it wouldn’t let me try the app otherwise). It installed fine, I installed the app but it would not launch.

So I rebooted hoping that because it was an audio driver it needed that. I received a BSOD multiple times, the failed file was: cmdhlp.sys, which is Comodo I believe.

I use the Comodo firewall. I had to revert to my previous version of windows as the repair did nothing and with a new install all of the system restores are gone.

Please advise.

Hi Mark,
May you please share crash dump?

It could be found as:


I don’t have memory.dmp or a folder called minidump, I’ve looked manually in the Windows folder and have carried out a search.

and you were on latest v6420?

Yes it’s V6420

Did/do you have other security software installed like another 3rd party anti-virus when BSOD appeared?

Yes, I have 360 anti-virus.

Have you tried uninstalling 360 to see if you still get the bsod?

It took an hour to get the update installed and the BSOD said cmdhlp.sys, which is comodo.

What makes you believe it is the 360 anti-virus that is the problem?

For one I have no other 3rd party security software installed on the same Windows and Comodo version. You and another user who also experiences BSoD with cmdhlp.sys both have a 3rd part AV installed, which points to cmdhlp not being able to function properly with another security software installed.

Okay, thanks for that information. I shall uninstall the 360 tomorrow and try again.

I uninstalled 360 anti-virus without any problems. The problem came when I went to install CIS over Comodo firewall. I thought that would be a simple matter, I was wrong. I now appear to be in some sort of Comodo limbo.

The installed installed the shopping program and Comodo Dragon, but then told me I had to un install the old Comodo program and then install CIS. I uninstall what is there under the control panel/uninstall which looks like CIS as there has been a partial install, and it goes so far then a message appears that I already have this account then it rolls back and I am left high and dry.

Now there is no 'old CIS firewall of any other Comodo CIS to uninstall but the message still keeps coming up when I attempt to install.

Any ideas please?

I found the uninstall tool, it worked great, so today I’ll redo the update to Windows 10.

I also started getting the BSOD in cmdhlp.sys after yesterday receiving Microsoft’s Fall Creator Update for Windows 10. This is on a machine that doesn’t run any other AV product (as far as I am aware).

In the end I resolved it by uninstalling Comodo Internet Security as follows:

  1. Boot Windows 10 into Safe Mode (without networking).
  2. On another PC, download the official Comodo uninstaller onto a USB stick from the link in Comodo Forum
  3. Run the uninstaller on the faulty machine.

It is now able to boot. I’m not inclined to reinstall CIS.

UPDATE: after successful boot I was unable to access the internet. It turned out that my network adapter was still binding to an entry called “COMODO Internet Security Firewall Driver”. Clearing its checkbox for that entry got me back onto the internet. Looks like the official Comodo uninstaller doesn’t do a thorough enough job.

Should be fixed please check with Comodo Internet Security v10.1.0.6460 - BETA