BSOD when connecting to Cisco VPN

The bug/issue

  1. What you did: Connected to a VPN using the Cisco VPN Client version
  2. What actually happened or you actually saw: Once I authenticated and the connection started, I got a DRIVER_IRQ_NOT_LESS_OR_EQUAL 0x00000000D1 BSOD that said inspect.sys was the cause.
  3. What you expected to happen or see: Not a BSOD :wink:
  4. How you tried to fix it & what happened: I deleted inspect.sys and it worked fine. I let Comodo recreate inspect.sys and it started blue screening again.
  5. If its an application compatibility problem have you tried the application fixes here?: N/A
  6. Details (exact version) of any application involved with download link: You need a contract w/ Cisco to download it.
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Yes. Open Cisco VPN Client. Click ‘Connect’. Enter username/password.
  8. Any other information (eg your guess regarding the cause, with reasons): Happens even with Firewall disabled, but stops happening if i delete inspect.sys

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file. Attached
  4. Crash or freeze dump file: Attached

Your set-up

  1. CIS version, AV database version & configuration used: CIS 5.0.163652.1142, DAT 7119
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe, Sandbox= Enabled, Firewall = Safe, AV = Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: XP SP3, 32bit, N/A, Administrator
  7. Other security and utility software installed: None
  8. Virtual machine used (Please do NOT use Virtual box): None

[attachment deleted by admin]

Just noticed two more things:

  1. It will blue screen even after deleting inspect.sys if the firewall is enabled. Here’s a table of the conditions under which it blue screens:

Inspect.sys present / Firewall on: BSOD
Inspect.sys present / Firewall off: BSOD
Inspect.sys deleted / Firewall on: BSOD
Inspect.sys deleted / Firewall off: works

  1. I can enable the firewall after connecting and it won’t blue screen; it just has to be off while making the initial connection.

There is an FAQ for this;

I’ll move the post to the CIS Install help board.

That fixed it, thanks. I spent a lot of time searching before adding the bug report, but for some reason I never saw that post.

We’ll good to hear that it still works :-TU