BSOD From Running Iobit Advanced SystemCare In FV Environment [M269] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?:I can reproduce the problem every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:To reproduce this download Iobit Advanced SystemCare from this page. Then right-click it to select run in sandbox. Then, once it’s installed, run a Smart Scan. It will blue screen the computer after it starts scanning for registry errors.
  • If not obvious, what U expected to happen: I would have expected that as it was run in the Fully Virtualized Sandbox it could not harm the actual system. I consider a blue screen of death to be something which a sandboxed program should not be able to cause.
  • If a software compatibility problem have U tried the conflict FAQ?: All relevant information is provided above.
  • Any software except CIS/OS involved? Yes, as mentioned above this is an issue shown with Iobit Advanced SystemCare.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: This may be caused because the software being tested in the sandbox is signed by “IOBIT Information Technology”, which is in the TVL. Thus, perhaps there is a conflict in the Kiosk between whether it should be allowed to affect the actual system, because it’s trusted, or isolated because it’s in the sandbox.

Also, I’d like to mention that this was brought to my attention through ad18, who described the problem in this topic. Thus, this has already been replicated by two users.

  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware) MiniDump File is Attached. So is the diagnostics report and the KillSwitch process list (although this is not useful).
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- CIS version & configuration: CIS 6.0.264710.2708. Database 15267. The BB was set to Fully Virtualized and everything else was set up as described in my article here. However, I do not believe the configuration to be important. This appears to just be an issue with the Fully Virtualized environment.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Please see above.
  • Have U made any other changes to the default config? (egs here.): Please see above.
  • Have U updated (without uninstall) from a previous version of CIS: No, it was a clean reinstall.
    [li]if so, have U tried a a clean reinstall - if not please do?: NA
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: NA
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Windows 7 x64 (Service Pack 1), UAC is disabled, administrator account, not a virtual machine.
  • Other security/sandbox software a) currently installed b) installed since OS: a=None b=none
    [/ol]

[attachment deleted by admin]

I think you covered all the important information. I have a Windows 7 64 bit. The similar programs to Iobit Advanced System Care are: Iolo System Mechanic, Wise Care 365, and ToolWiz Care. CIS 6 is the only security software on my computer. Please let me know if you need any more information. I don’t think my computer saved the MemoryDump. I hope the CIS 6 diagnostics file is enough.

[attachment deleted by admin]

@QA: Please note that noes on replication are in first post in topic.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

This is fixed with version 6.1.275152.2801.

Thanks for the fix Comodo.