BSoD caused by cmdboot.sys

COMODO Firewall Version: COMODO Firewall, cispremium When installing win10 / 32-bit system, a serious BUG occurs, restarting the system directly blue screen, unable to enter the system

Hello woyaoba,

Thank you for reporting.We will check this issue.
Could you please check your inbox via PM and send us the requested logs for further analysis of the issue.
Have a nice day!

Kind Regards,

is blue screen related to BAD_SYSTEM_CONFİG_İNFO

Yes,BAD_SYSTEM_CONFİG_İNFO is one of the BSOD error code and it’s created by corrupted windows system files.
Have a nice day!

I tried to search for the two files “Minidump” and “MEMORY.DMP” in the "% SystemRoot% " directory, but unfortunately none of them were found.

In order to exclude all other factors, I only installed the original ISO of win10, and then only installed “COMODO Firewall”, the result is that the computer reproduces the blue screen after booting!

I then tested the same problem with other brand computers!

My information for installing Windows is:

Windows   Windows 10 Enterprise LTSC
Version     1809 x86
OS build   17763.107

This version of 64-bit system is normal.

In addition, I tested the latest release of Windows 10 VB-2004 x86 and no blue screen appeared, but COMODO Firewall did not start normally!

You need to make sure your system is set to create kernel memory dumps and you have enough space for the dump files to be created. Do you know the details of the blue screen as in what did it say for the cause? Does it reference a driver file name?

I fixed the url. Eric

can you share BSOD or STOP code :P0l

Followed the "" steps to set up the computer, but the computer still did not save the dump file, I can only send you the blue screen shot . In addition, there is a problem with the attachment "cmdboot.sys" and the old "cmdboot.sys" without problems

Hello woyaoba,

Could you please share us the requested logs for further analysis of the issue.Btw Please check your Windows updates and drivers are they are in up to date.
Have a nice day!

Installed 2020- 06 cumulative update for Windows 10 Version 1809, suitable for x86-based systems (KB4561608), but the failure still exists,Perhaps this is the reason: “cmdboot.sys” located at the bottom of the system started prematurely, resulting in a blue screen for windows startup, blocking the recording of “kernel-memory-dumps” and “system log files”. Therefore, these files cannot be found in the system files. I provide this version of the Windows system download address for you to test:

file name: en_windows_10_enterprise_ltsc_2019_x86_dvd_892869c9.iso
SHA1: 88af607f1e752761577d21f2b7aa98692809bf66
File size: 2.82 GB
release time: 2019-03-15


Hello woyaoba,Let me check that and update you.Btw if possible could you please share the requested logs.
Have a nice day!

I am also getting the same cmdboot.sys error PAGE FAULT IN NON PAGED AREA

So that means the most recent version of Comodo has a bug in it.

I uninstalled Comodo and made certain it was completely uninstalled, in order to update to the newest version. After noticing i had a version from 2019.
Boy. I wish i would not have done that. This bug locks you out of your PC with no hope of getting in. There is a work around. And I only found it because
I am familiar with BSOD. Not one i’ve never recovered from. Anyways. After an uninstall of the 2019 version, i also used the CIS Cleanup tool. Rebooted.
Reinstalled the latest version. Rebooted. BSOD. It will reboot 3 times before going into ‘‘advanced’’ rescue settings by it’self. System restore was denied.
All tree System Restore backups I had failed. After failing at every possible option in order for the Computer to start normal for about 4 hours. I decided
to go into Advanced Start-up options menu and Pressed F8 which from the Start-up menu is the option to ''Reboot / Pause any Antivirus from loading…
That got me back into my PC. Started all over toward another attempt at Installing CIS. Thinking I had made some mistake. Same thing. I was thinking
of downloading an Offline installer of a previous version in hopes to have this sorted out. The screen looks like the Camera grab that the OP Posted.

Took the better part of the day to try and solve this myself. Was not able to so I finally decided to post about it. And found this un-updated thread on it.

Super Babylon. Could you provide us with a full memory dump? Please follow the guidelines posted by futurerech in the above to produce one.

Could you tell us what version of Windows you are using?

If you need a previous version of CIS that runs stable try 6882. It can be had from Comodo Forum .

I’m using Windows 10 / 32bit. Can’t seem to produce a Memory.dmp. I tried re-enabling the clear page file on shutdown. Which i had enabled to escape the NON PAGE FAULT IN NON PAGED AREA error. I also went to Advanced System settings. Via right clicking properties on PC / Adavnced System settings / System Properties / Start up and Recovery, in order to Procude the MEMORY.DMP in System32, and I’m not seeing it. Can’t seem to locate one in a Search either. It’s likely my system is Corrupt. Been meaning to Re-install Windows. I believe this is from trying to elminate some of the 1,000 unecessary ‘‘options’’ Windows 10 tries forces on us, and re-enables without your permission. I will likely install a previous version of Comodo from this point. If there are any other suggestions let me know. If i can help. Thanks.

Post Edit: Downloaded a previous version of CIS version (offline installer 80.9mb) and that seems to be a temporary fix on the issue. Even thought it’s at earlier version. At least I do not have to deal with the consisten NONE PAGE FAULT IN NON PAGED AREA / CMDBOOT.SYS error. According to the version of installed CIS, it reads as version Not sure why. Can someone she some light here. On that. Since the Offline installers says But the cmdboot.sys error is gone for now. As long as it’s brought to someone at COMODOS attention. No one will have to put up with this error. And actually something about the version im using now v12.0.0.6882 i noticed was when I go to the firewall to block a program from the running processes tree it opens the process windows like the newest version did, but at least on this system i could see the icons to the processes, where there were icons. And with the newest version. No icons present. They were there but all blank. Hope all that made sense. Thank you all. I will check on this later if I could be of any type of assistance.

I had the same error witch i solved by changing memory timings if i remember correctly.
For me this happened or can happen after i 0 free space of disk.

If you use the new AMD Cpu it would be a great idea to spam your motherboard manufacturer for a Bios update that brinks memory stability.

Please check with thank you.

I have the same issue.


after the restart Windows crash in Bluescreen.

The installer give me a Error thats the Internet is not connect, but is its.

Did the blue screen tell what file was involved in the crash? What was the error name of the Blue Screen.

The installer give me a Error thats the Internet is not connect, but is its.
I assume you were running the online installer. In that case you have to add the following two lines to Windows HOSTS file to point the installer to the beta servers:

Please check with thanks.