BSOD after second restart ( beta)

Hi, I just installed the beta version of the CFP v3. I have a clean pc so I marked all the files clean and did the profile (I just reinstalled windows).
Everything was running fine after the first restart, until the second one came, and a huge BSOD with an error message saying “SESSION3 INITALIZATION FAILED” don’t know what it means but my XP SP2 wouldn’t restart until I uninstalled the firewall.
I have done this game of installing and uninstalling after the BSOD 3 times now and I’m kinda tired, If you have a solution please let me know, till then back to v2.4

This is the error:

STOP: 0x0000006F (0xC0000022, 0x00000006, 0x00000006, 0x00000006)"

There is no minidump because it happens just before windows can boot, so I think it’s a serious bug…

Have you tried stopping your other security software (AV, CBOC, etc…) from starting up at bootup to see if one of them is causing the BSOD. I had the same problem that you are having and I had to stop CBOC from starting at bootup for the first time after installing the firewall in order for the firewall to find the needed Windows drivers. Once I did that I am back to normal with everything starting at bootup again and have had no trouble since.


No I haven’t but if NOD32 which is my only other security software is causing this after 4 years of a blissful use, I’m not willing to give it up…
Besides, I removed all entries relating the CFP startup, including the service and still the machine wouldn’t boot, I believe this could be something related to hardware drivers not well handled by Defense + (I have an AMD X2 processor with dual core optimizer installed -the driver from AMD- and a nvidia 7600GT vivo edition -which also loads services on boot).
I sincerely don’t see how this could be related to anything else than the firewall when it only happens when you install the firewall.
I agree that the concept of Defense + is awesome, but compatibility should be taken care of by comodo, since they are the ones causing the problem…

I agree that I think it is Defense+ and drivers where the problem lies.

In the bugs thread there seems to be quite a few BSOD’s including my own so I would imagine the Dev guys are looking for the cause of this bug already. If you haven’t already you might post your problem and what happens in that thread as that is where the dev guys look first from what I hear.


Generally when you have a blue screen there is also a file named which is problematic.

If anyone is using CCleaner, you’ll want to uncheck the Memory Dumps so called “cleaning”.

It won’t dump the memory as Windows haven’t booted. And it’s not always it says what file is resposible for crashing your computer.


It might be possible there’s a kind of conflict between old install : CFP 2.4 and the new one.
For theses reasons, when you are installing a major version, because CFP 3.0 is a bit different, you should uninstall properly the old software, remove all links by using program such as RegSeeker and reboot your PC a last time.
Then you can install the new one.

I had same troubles with Blindwrite old installation and Daemon Tools Pro, blindwrite had been uninstalled but some drivers were still loaded and they were unstable.
The solution was at least removing links from Registry.

Even if the author is serious and building a good uninstall program, unfortunately it remains very often some files and sometimes it can be still loaded at next reboot even when you don’t need them because uninstallation programs are not perfect.

[quote author=PegHorse link=topic=11465.msg81288#msg81288 date=1186856261]
It might be possible there’s a kind of conflict between old install : CFP 2.4 and the new one.
For theses reasons, when you are installing a major version, because CFP 3.0 is a bit different, you should uninstall properly the old software, remove all links by using program such as RegSeeker and reboot your PC a last time.
Then you can install the new one.

Yeah but even if this is the case, the last time I searched the regkeys for comodo and deleted them, my machine ended up locked, don’t ask me why but that’s what happened, and besides I have not read anywhere that such a clean uninstall of previous versions is necesary…

You’re right MasterTB. That’s a good point. I’ll edit some threads to state that everyone should uninstall previous versions. This is kind of a given when it comes to non-final versions for most critical software like firewalls.

Hey, I had the same exact problem, which I posted in the main bug thread. I fought w/it all weekend, disabling FW, then other services, startups, etc. It wasn’t a conflict w/any other application, and FW was installed in SafeMode w/o any other apps running.

I finally got the GUI open in SafeMode, and set D+ to Allow All, and turned off Image Execution Control.

Solved it. I think only Allow All was needed. Then after reboot and login to Windows, I reset D+ to Learn All, and turned Image Execution Control back to Normal. So far this has worked.

So it seems that D+ on Learn Safe Only was blocking some part of the boot process.

And believe me, this is reproducible on my system… Screenshot of Process Explorer with everything that was running during this time attached.


[attachment deleted by admin]

Hi, finaly I found out that Defense + has a Memory Problem -like my grandma- and it’s not taking it’s pills. After the first restart -the one you have to do after install- Comodo doesn’t seem to remember the rules it created on Defense +.
I could start using the program by manualy adding al my Program Files and my Windows directory into the safe list, that did the trick for me, BUT -BIG BUT- if somehow your sistem crashes and you see yourself forced to reboot windows the hard way -the infamous reset button- then voila!!! BSOD again, because Comodo didn’t have time to close the session and there are no more Defense + rules the way they should be.
So, you have to start in safe mode, uninstall comodo, restart, and install comodo all over again, fortunately now you can export your config, so it’s getting easier each time, even though it’s VERY ANOYING. (:AGY), I found it to be the only solution so far…

As I reported in the main bug thread yesterday, turns out it wasn’t the D+ Security Level. It’s Image Execution Control that is at fault. It has to be disabled in order to avoid the BSOD.

kail has found that with every change it completely rewrites the registry, adding to it as it goes, increasing in size each time. Ouch.


And … Is it safe to do that?? How does it influence in Comodo’s overall security??

Well, obviously it decreases it, but not as much as setting D+ Security Level to Allow All, which I think would also work (another user reported it to) to get around the bsod. The thing there is that disabling IEC only disables one thing, but still leaves the security/monitoring provided globally by D+ intact, for the different types of application interaction, and different hijacks.

To be honest, I’m not sure exactly how the two aspects of D+ work together, but it seems that setting Security Level to Allow All effectively turns them both off. Just disabling IEC, then, is safer.

And after all, we’re beta-testing. :wink:


Yeah baby, BETA!!!

One question though, remember I said I had to uninstall and reinstall and so on… well I cannot install no more. Is there a way to clean up the registry so that I can, I’m beggining to sense that there’s something messed up there !!!
Every time I try I end up with a BSOD, and I cannot find a way arround it, it seems I’ll have to go back to v2.4, unless someone can tell me how to delete those locked registry entries that comodo writes. (:SAD)

The only ones I have found to sometimes be left are HKLM/System/Software/Comodo/Firewall/… remove if you find it. Other than that you can search regedit for Comodo or CFP entries. If you find Legacy Keys, you’ll have to right-click, select Permissions, and make sure you’re added for full control, in order to delete.

If you want, you can use a cleaner app like ccleaner or regseeker - both free. Just be sure to use the option to back up the registry prior to letting them delete stuff. I’ve never had a problem, but you never know…