Browser times out trying CM

My browser times out when I try to access Spywareblaster (since-uninstalled) threw up when trying, but on other systems that don’t and never did have any antispyware, I can not access comodomeet either. This has been for 2 weeks now since I started trying to access the site. I’m on a campus network and have not had a chance to try to connect off-campus. Perhaps the site-licensed AV product, or the enterprise firewall is blocking but I never needed to configure a proxy for anything?

I’m on XP SP2, had computer assoc. eTrust AV for last 2 years, tried Windows Live OneCare for a few weeks, also tried ZoneAlarm for a week, had spywareblaster. CAV & CPF currently installed along side Win Defender & SpyBot. Cisco VPN also installed but dissabled. MS Firewall also dissabled. CPF rules currently set up merely as the flash tutorial prescribed. No problem with OpenVPN or any other connection near as I can tell, but I do have IE7, FF2. Previous to the CPF flash tutorial I was getting a ton of IGMP & ICMP messages about host/port unreachable when attempting to connect with, odly enough, comming from a 169.x.x.x IP even though DNS resolves to a 216.x.x.x IP (a lynxsys rtr perhaps messing up DNS?)