broken cis

after another computer malfunction cis couldn’t start anymore and couldn’t repair itself either.

since its big file can’t attach it so here onedrive link: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Hi Cuser,

Thanks for providing the dumps. Forwarded the dumps to our developer for investigation.
Please check your Inbox for private message.

Kind Regards,

First of all, thanks for wonderful and extremely useful program. It’s second thing which is installed on most of OS when first is OS itself.
Second, indeed, reported problem is extremely common and painful and existed for a very long time (years).

To reproduce, may be it’s just enough to make emergency shutdown of system (to remove power supply)
System must get broken files, repair them on start - and here it is, COMODO just not starting and can’t fix itself and can’t report anything direct about problem.

If that’s not enough, configuration must be more complicated: please create a virtual machine which have dedicated free HDD. I.e. it work on physical drive. It’s not hard task if you have two hdd in PC, one of which is used for boot and other exclusively for system in VM.
And then practically any non-standard way of booting/ending VM leads to broken files and, unfortunately, to broken CIS. Power if off instead of shut down, or put in sleep - over.
So far only way was reinstalling CIS.

Here is my report, but probably it’s not required.

And a bit of addition:
First of all, this all looks like COMODO still in protection mode after reboot, but it can’t show warnings and blocks every possible dangerous action on PC.
After first boot, COMODO diagnostic reported some error and failed to fix it automatically.
I tried to go into safe mod, but failed - ms-config reported assess denied.
Then tried to repair&uninstall CIS, failed even to open control panel - opening was blocked with some sort of not enough memory message.
Then tried to go into Safe mode with cmd command - worked, got into Safe.
In the Safe mode Control panel worked, but both CIS repair&uninstall failed. Yep, uninstall too.
So, used SFC and DISM and then again SFC to repair system. Finally seems they reported all fine.
Now, CIS diagnostic reported no errors too.
After rebooting in normal mode, COMODO still blocks everything perfectly - COMODO vbs blocked, control panel blocked.

Well, seems it’s very hard to move COMODO out of place if it doesn’t really want to. Good job. Guess time to restore disk image.
Actually no thanks, just used ciscleanuptool in safe mode and after pair of reboots reinstalled. All fine.
Tool reported only problems with registry keys and this specific line: “Cannot remove ‘\System\VritualRoot’ registry key. Error 5: Access is denied.”