Boomerang for Gmail no longer works

I installed the Chrome Boomerang extension for Gmail a while ago. Worked for a while; but then the icon disappeared and I couldn’t prep messages for future transmission. So I reinstalled the extension and it worked — for a while. Now, not even reinstalling the extension makes it work again. I contacted Boomerang support; they’re baffled. They tell me they built the extension for Chrome, not for Chromium-based browsers; they’re mystified it even worked in the first place. CD tells me the extension is both installed and enabled. Yet I don’t see the Boomerang control in my Gmail window. So I’m working it from the other side: Can someone here offer an opinion as to why this extension worked before but not now, and how I can get it working again?

Thanks, all.

CD is based on Chromium 36 which is outdated. We expect a release of Dragon based on Chromium 42. May be that will make it work again.

I’ve been putting up with Gmail whining about me using an outdated browser for months now (about three days after CD last updated; but that’s another thread entirely). Any idea when the next CD will drop? Thank you.

I’m now running CD; CD itself assures me I’m up to date; the executable currently on the web site installs I’m still having problems with the Boomerang extension, to the point where I have to trash it from extensions and reinstall it if I want to use it. Good thing Boomerang came out with an app for my phone. But the original question still remains: Why doesn’t Boomerang work in CD? Recall that Boomerang techsport advised me that they were amazed it worked in CD at all, as they say it was built for Chrome, not Chromium. So what’s the difference; and more to the point, how does this get resolved so that the extension stays functional all the time?