BOClean won't open from tray

I’ve noticed that while using Windows Vista, I cannot get the BOClean utility to show me the menu on right-clicking the icon on the task bar. I cannot seem to get the program to run so that I can configure options the way I want them. When I do either right-click or double click the system tray icon the only thing that happens is that it turns red and never opens. The only way I can get the icon to return to what looks normal is to reboot but it still won’t open a menu or perform any automated features. Is there a fix for this?

Hi 1972vet, welcome to the forum :slight_smile:

The red tray bar icon indicates that the BOClean menu should be open. Are you sure it is not somewere outside your desktop ? You can check that by choosing a higher screen resolution.

Greetz, Red.

Thanks Rednose…that was indeed the cure for my issue. In Vista, I have the sidebar that opens on startup. It seems when I try to open BOClean from a right-click on the task bar, it does open as you said but it was hidden behind the sidebar. I clicked to configure BOClean to see if there is an “Always On Top” option that I could check but found none.

It would be nice if, on the next update to the software, comodo could add that to their “To Do” list. Thanks again! :■■■■

You can add that to the Wishlist if you like :

Greetz, Red.

Hi there … over the years, we’ve had complaints of “please put it on top of all others” and just as many “don’t do that” when we did. We went for another solution that isn’t perhaps documented as well as we’d like in the help file, we DO issue an “always on top” command but Vista ignores that by always putting the sidebar at the top of the “Z-order.” So what we did as of a few versions back was made that menu “moveable AND sticky.” If you open it, you can “grab” the top of the menu, and drag it anywhere you’d like it to be and it should show up in that position thereafter. Seemed to be the compromise that resulted in the fewest complaints. :slight_smile:

Give that a try though, the former “always on top” trick doesn’t work in Vista, but this one should …