Blue screen on Vista when resuming from sleep mode

Since installing Comodo Firewall Pro (version prior to I get a “blue screen of death” every time the computer wakes up from sleep mode. Usually the error says “bad pool caller”. I uninstalled the firewall to verify that it was the culprit. With it uninstalled I was again able to resume from sleep mode as normal. I then reinstalled the firewall (this time I installed and the sleep issue returned.

Any ideas why this is happening or if there is any workaround?

Here are my system details:

  • The version of Comodo Firewall Pro Installed

  • Your Internet connection type (dial-up/cable/Direct connection/LAN etc)

  • Operating system and Service Pack Level
    Vista Home Premium 32-bit (all updates installed)

  • How you are logging in to the OS (Admin, User)

  • Other real-time security applications installed (AV, AS, HIPS etc)
    Avira AntiVir PersonalEdition Classic
    AVG Anti Virus 7.5.516
    AVG Anti Spyware (Turned off)
    Spybot Search and Destroy
    Windows Firewall
    Windows Defender

  • Security related applications which have been removed/disabled before installing CFP
    Norton Internet Security was previously installed. I uninstalled it prior to installing CFP.

  • Security related application which have been removed/disabled after installing CFP

  • Detail the problem, such as which applications are running when you have the problem
    Windows sidebar
    Google Desktop
    MozyHome Backup
    OmniDrive updater
    Taskbar Shuffle
    Webshots Desktop
    Magic ISO Virtual CDROM Drive
    Microsoft Onenote New Sidenote
    Sync Center
    Realtek HD Audio Manager
    GrooveShark Sharkbyte helper application

  • Please inform us if you have created any custom rules

Thank you for your help!

Are you actually running all the real time security software you list at once? Comodo may simply be the last straw for your OS if you have multiple AV, multiple firewalls, Teatimer & Windows Defender all running at once. :wink: I have no problem with Vista Ultimate and sleep/resume, but I am only running CFP, Avast, Windows Defender. Suggestion would be to turn off the Windows Firewall and Spybot, uninstall one of the AVs and use an on-demand and a real time if you really want two. And if all works well, you can try adding back some of the other security software later and see where it breaks.

Tea Timer has always been a problem for me. I suggest you disable it and try again.

It could be that Norton is not completely deinstalled, and some leftovers are interfering with CFP 3. To be sure use the Norton Removal Tool you can find here :

Greetz, Red.

No, I’m not actually running all of those security programs at once. They’re all installed, but I usually disable most of the real-time agents (except for maybe one of each type). And I wasn’t running Tea Timer.

I tried the Norton uninstall utility and it didn’t resolve the issue.

So I resorted to uninstalling all of my security apps except for Comodo. The sleep functionality then worked okay. So I began installing the other apps one at a time. I determined that Comodo was conflicting with both AntiVir and Ad-Aware 2007. With either of those programs installed, it would blue screen when resuming from sleep mode.

I wonder if anyone else can reproduce this? It would be nice to be able to use Comodo with these two programs.

Well, I thought that I had the issue solved… but I still get a blue screen when resuming from sleep mode about 50% of the time. ??? (It used to be 100% of the time.)

The only other security programs I’m currently running are Spybot S&D, Spyware Doctor, and AVG Anti-Virus. I’m not running Spybot’s real-time scanner, but I am running the other two program’s realtime scanners.

This getting is ridiculous. Comodo Firewall can’t honestly expect to be the only program installed on your computer, but it appears to conflict with a majority of the security related applications out there. (:AGY)

It looks like I’m going to have to look for a new firewall and hope that you can get this issue resolved in the future.

What is the text on your BSOD? If it is set to automatic reboot, go to my computer/properties/advanced/startup and recovery and uncheck “automatic restart” Also, submit your mini-dump at per the instructions there so the developers can take a look and see what is happening. I don’t use spyware doctor, but have the rest running under Vista Ultimate with no problems with sleep mode.