Block ICMP Request (Stealth mode for Ping request) [Resolved]


I have a problem blocking an incomming ICMP request (ping)

The rule: Block ICMP In/ From Any /To Any / ICMP Any

doesn’t seem to work while using e.g. the Shiplds UP! Firewall test (common ports) on

Any ideas are very welcome!

Many Thanks,

Are you using a router? They often respond for you.

I posted similar question yesterdy and got similar answer.

As usual, the good folks at Comodo were right in their answer. It WAS my router (D-Link) responding to ICMP pings. I configured that properly and now I pass all “Shields Up” tests.

Hope that helps

It’s probably your router.
There should be an option to block ping in your router’s configuration, like this(using D-Link):


If you want to test CFP3, you must plug the network cable directly into your computer.


Hi all!

Many thanks for your answers! I have a Fritz!Box Phone Wlan but I failed trying to find these settings. I’ll contact the AVM support.

Once again, many thanks!


Glad you found the problem so fast. I’ll go ahead and close this. PM me or another moderator if you need to open this topic.