Black screen showing only cursor at start up - Win 7 Ult. x64

So, I decided to use Comodo Programs Manager in order to delete a couple of things which were unnecessary security loopholes.
After a reboot, and before entering Windows, I got a message about forcing delete before a black screen with only a mouse cursor.
There was/is no HDD activity.
So, although it’s almost completely useless (unlike the XP installation disc) I put my Win7 disc in and booted from it, where it immediately found issues with startup and “fixed” them, before suggesting a reboot.
Sure enough, it fixed the Comodo message which preceded the black screen and mouse cursor, though that is of no help, but that’s in keeping with the Win7 installation disc so I wasn’t surprised.
I tried to use the disc again in the hope I would now get to manually use the [ah-hahahahahahahaha!] “startup repair” option; which I did, and it informed me my discs weren’t broken and all the usual HW check which are nothing really to do with startup problems which wouldn’t be blindingly obvious to any - such as the broken HW it tested for.
So, as there’s no longer a non-destructive repair install and a power user with a brain who constantly tweaks their machine is NEVER going to be using the resource-hungry travesty (for virus-downloading teens and foistware-afflicted pensioners) that is Systm Rstr, I’m stuck with command prompt.
So, I’d like to ask for the complete Command Prompt instructions for rectifying the issues caused by this software; including those which bypass the virtual “X” drive and mount the C drive - because I’m tired and have already bruised my knuckles punching my desk door four times already.
To think this all started this morning, with MSI installer and permissions totally locking me out of installing, uninstalling, running SFC or changing service states on my computer many “access denied” messages or errors somehow related to stuff not working due to permissions.
I’ll keep searching for Command Line solutions, as I want this computer working and, as stated, MS have removed the awesome non-destructive install fix which was included on XP discs, so it’s Command Line or NOTHING. I guess simply they wanted to be more like Linux/Unix!!!

after an hour or so sitting, seemingly doing nothing, the computer rebooted - to the same black screen and cursor[?!].

The reboot happened again, after another period of around an hour.
Anyway, this doesn’t appear to be a problem which could be fixed with BCDEdit or anything pertaining to MBR issues or such.
It’s evident the issue caused by Comodo Programs Manager is presenting after boot, as Win receives a flag that the boot was a success.
Therefore, if I am forced to use a Linux LiveCD/DVD to attempt a repair [as always!!! - thx, MS], which files/folders/entries will I likely need to modify/delete/replace in order to resolve this?

I can’t run MSConfig from the installation disc repair option Command Prompt as I’m not logged in and don’t even know if there is a way to log in or elevate this prompt from outside of Windows.
I can, however, run RegEdit, but I would need to load the correct hive as, by default, it appears to load hives for the repair environment.
In this case, which hive shall I install from the “C” drive, and which entry to I need to delete to prevent Comodo Programs Manager from attempting to run at start up - if that’s at all possible?
Or, is there a better solution?

It gets better.
If the “repair” tools on the installation media for Win7 weren’t already useless enough, I now can’t even access them, and the disc moves directly to “Install Windows” without giving me any options at all.

I performed a quick search but couldn’t find any web forum threads relating to exactly why Windows has now denied me access to ANY of the limited repair functions of the DVD, to only dump me directly into an install process.
Now I’m downloading a Knoppix (Linux) DVD in order to access the drive and move some registry hives around in order to see what happens.
It’s looking like I’m going to have to go with creating a Windows 7 LiveDVD to be able to utilise ANY tools of ANY worth, pertaining to fixing my computer. This is going to be a learning curve.
Thanks again, MS, for removing the Repair Install from later versions of Windows which was available on the XP CD. Life is soooooooo much easier without it - NOT!!!

Couldn’t run SFC from the repair options on the Win7 DVD, even in an off-directory capacity, as the repair flag set by the disc was preventing usage.
I no longer have that problem as, for some reason, I no longer have access to the repair tools!!! only install.
Tried replacing backup registry hives using Regedit within the limited CMD prompt. This was while I still had access.
This made no apparent difference so I put the original hives back using Knoppix, due to no longer being able to access said prompt.
Now been trying to run Wine’s Regedit (as suggested to others online) except it’s a joke! It’s only a sandbox environment and what’s loaded in it is a virtual Knoppix registry, with no ability to “import” a Windows registry hive on account of its virtual directory structure not including genuinely mounted drives - such as the one containing my broken Win7 install!
At the very least I would really like to find a way back into the registry, so I can re-enable the god-awful Sticky Keys and attempt to use them trigger some windows at the KSoD.

Tried Comodo Rescue Disk but it offered nothing more than running Knoppix LiveDVD in my case.
I guess it would have been good had I had a malware infection, but who gets malware when running CIS combined with script blockers and the all-important total avoidance and blocking of anything remotely ActiveX related?
As it was loaded at the time, I did use it to rename the CPM folder and attempt to force Windows to get upset or recognise something amiss.
It did pause and switch of the monitor temporarily, but nothing more than that before I arrived back at the KSoD.
Anyway, I’m now back in the severely limited CMD prompt of the repair [misnomer] tools on the Win7 disc.
I’ve imported a default REG file for services (after backing the complete registry up, of course) but, again, just a slight hiccup with the display at Win7 start up, before the familiar KSoD.
I’ve tried the [ahem] Start Up Repair a few times since trying to get Win to realise something’s amiss but still the same report akin to “What’s your problem? Win loaded just fine at last boot”.
Unfortunately for me, I disabled/uninstalled Sticky Keys, so have no chance (that I’m aware) of invoking the web at the KSoD, in order to download and run PrevX’s FixShell.exe - which won’t run without the correct environment loaded into memory.

I was going to try to make a Windows7 LiveDVD but instead opted for a parallel install.
From here, I’ve managed to run an SFC for the affected OS using offline commandline switches “offwindir” and “offbootdir”.
First though, I still had to delete the pending.xml from a directory within the affected OS, else even the parallel install wouldn’t let me run SFC on the other; even with the switches.
It appeared to work, though didn’t report the usual percentage completion status while doing so.
Anyway, it didn’t change a thing regards trying to boot the system.
I think I may now need to try to somehow merge the working registry of the parallel install into the potentially broken registry of the other, or at least edit hives of the broken OS without messing up the parallel, working, OS.
Also, I need to find out how to extract and reinstall all Services into the broken OS.
It’s been ONE WEEK now; much more proficient [sarcasm] than having that inferior repair install from XP which would PERFECTLY [despite what MS claims] FIX A SYSTEM WITHIN THE HOUR.

I need viable all-encompassing solutions to this - for the sake of everyone in the same situation.
I had an uptime of less than two weeks!
I’d just downloaded and installed >100GB of software two days prior to being “taken out” in this manner.
I NEVER HAD TO REINSTALL XP: SFC, CMD and Repair Install were all tools needed for every problem.
MS has taken down my computer at least four times; only on a fifth occasion was I able to repair it by repairing the MBR from the restricted Command Prompt [I think I had to even use diskpart to get around the restrictions in order to perform that one!] of the erroneously named [99% useless] Repair Tools of the Win7 installation disc.

I could’ve now inadvertently trashed my hives.
Oh, MS! Tell me again how the Repair Install was rubbish, so much so that you chose to replace it with such an AWESOME AND COMPLETE SET OF REPAIR UTILITIES!!!

I now logged into the disc tools in order to reinstate the backed-up copy of the registry hive of which te modified version didn’t work; ONLY, Windows wouldn’t let me choose the Command Prompt and, instead, automatically did an error check on my hard disk [WINDOWS KNOWS BEST!] before requiring a restart… BACK TO THE SAME BSOD!!!

Nope! it’s convinced there must be disk errors.
At least I can cancel the operation.

Back in Regedit, trying to reinstate the backed-up entries = ERROR IMPORTING or ERROR DELETING or NO PERMISSIONS PAGE allowing me to rectify the situation.
Thanks MS, for allowing me to make a back-up of part of my registry, alter it, break it and then NOT ALLOW me to reinstate the working registry back-up.
This gets better.
There must be a commercial reason for this… but I can’t - for the life of me - figure out their game.
I guess they were simply trying to bury Win7’s Vista travesty origins, but some things slipped through - such as UAC and the Search function - which doesn’t!
Perhaps they already had the Fisher Price [broken] GUI, personal-databasing probe-ware THAT IS Win8 lined up for victims, and needed some kind of forced/planned obsolescence in order to attempt to make us buy the moron-targeted UEFI-killswitch rubbish.

I have been using a disk imaging utility for a few years now and it has saved my hyde several times.

I started out using Macrium Reflect then switched to Easeus ToDo Backup Home. Both are good and free and all you need are an external hdd and a blank CD to make a boot disk. It takes about 35 minutes to back up or restore my C: volume using 45GB of 250GB HDD. The backup file size reflects the data size not the HDD size. If your hard drive explodes, pop in a fresh hard drive, boot with the CD you made and the ext hdd connected to USB and re-image, rather than start from scratch. I make a back up at least once a month and trash older images except the fresh install without apps.