Big problems with User Interface for a first time user of System Cleaner

When I first start the brute a pop-up tells me it is updating various applications that I knew were exactly how I wanted them, and I knew that I did NOT want them updating.
I could not stop it or close it and I almost pulled the plug and shut down the computer, but chose to wait till it completed and then restore my system from an Acronis image. If I had no Acronis I would have panicked.
When it finished I was pleasantly surprised to see no change to any of my applications.
That was last night with the Portable version.
Same again today with the Installer version.
But this time I noticed that after it finished updating all the applications it said it had finished updating System Cleaner, so I guess it was not updating my applications but information files telling System Cleaner of the GO/NO-GO registry areas used by my applications.

I expect a System Cleaner to tell me what it would like to clean and await my selective authorisation.
When instead it burst into a full automatic fixing / updating session upon launch it rather knocks by confidence in Comodo.

I recommend that when the Cleaner is updating itself it should VERY clearly show that it is having NO effect at all upon the applications, and a Pause/Continue button would be reassuring.

Several times I ran this, and each time was unable to close until I put Task Manager onto the job.
Eventually I realised you not only omitted the standard RED close-down cross in the top right corner, you actually concealed a microscopic cross on a translucent background outside your window and buried in the background clutter of a Google search or whatever else happened to be under it.

Having seen the controls that are outside your window, I tried Help and got nothing at all. No explanation, no nothing, just a button that does nowt.
I quickly realised that Help was omitted from the Portable version, but supplied with the much larger non-portable. I downloaded that and found it was not so.
I extracted and found there was no help file. Most of the space was occupied by an *.msi file.
I reluctantly installed the Non-portable version and launched it.
Again no help, but it did say it was not available, and then there was an additional pop-up/progress bar as help.chm was downloaded.
a. Why can the Portable version not download help.chm when requested ?
b. Why is there no highly visible link for downloading the help.chm when downloading System Cleaner ?

Please note that I (and no doubt others) have downloaded System Cleaner due to advice on the CIS forum that a clean install of CIS may need the use of RevoUninstaller followed by use of System Cleaner.
During the course of which the computer is totally unprotected - very bad condition if the Internet has to be re-connected to download a help file that we thought was included in the installation.

In my case no harm no foul - I discovered the problem on a dummy run. Others will realise toooooo late.



  1. CSC makes an update when it is first launched to check for the programs installed on the user’s computer. Please also check this post:;msg322038#msg322038. In addition to that explanation, we need to assure you that during those updates nothing is deleted from your pc.

  2. The Help, Misc, Minimize, Maximize and Close buttons won’t be outside the window in the following version.

  3. As for the Help, this will be implemented in the next version.

Thank you for your support.

Thank you for the link.
I am now satisfied that the start-up updates do not affect my system,
but my initial reaction was that of a novice gardener advised by a neighbour to get a Chomper Deluxe,
and when he bought it and opened the box a chain saw fell out, switched itself on, and tried to take his leg off ! !
A few decades of aggravation from computers inclines me to always expect the worst possible outcome.

I look forward to the improvement 2 and 3