Battlefield 3 and Defense+ Enhanced Protection Mode Problems

A. The Bug/Issue Information: When the Enhanced Protection Mode of Defense+ is enabled it causes laggy movement and control issues within Battlefield 3. The problems are only evident whilst on a map. For example, the problems are not evident on the in-game menus. Also, it is the same problem regardless of singleplayer, co-op or multiplayer.

    1. What you did: Enabled Enhanced Protection Mode from Innstallation Defaults, the tried to play Battlefield 3. Tried in singleplayer, co-op and multiplayer.
    1. What actually happened or you actually saw: Mouse and general movement controls are laggy and sometimes unresponsive, seems as if the game receives movement indications slower than when Enhanced Protection Mode is disabled.
    1. What you expected to happen or see: Expected the game to work as it did when Enhanced Protection Mode was disabled.
    1. How you tried to fix it & what happened: Have tried adding bf3.exe to Trused Files list, Defense+ Rules list and also Execution Control Exclusions list. Problem is persistent. Disable Enhanced Protection Mode and problem is resolved.
    1. If a software compatibility problem have you tried the compatibility fixes?: Yes
    1. Details & exact version of any software (execpt CIS) involved (with download link unless malware): Unknown version number for executable file. However, it is retail Battlefield 3 Limited Edition from EA Origin Digital Distrobution and is auto-updated.
    1. Whether you can make the problem happen again, and if so precise steps to make it happen: Enable Enhanced Protection Mode and try game.
    1. Any other information (eg your guess regarding the cause, with reasons): I believe the game is getting control events slower than previously with Enhanced Protection Mode disabled.

B. Files Appended

    1. Screenshots of the Defense plus Active Processes List (Required for all issues):

Page 1:

Page 2:

    1. Screenshots illustrating the bug: Unable to provide screenshots illustrating the bug. However, I have uploaded two videos to YouTube showing the game with and without Enhanced Protection Mode enabled.

[li]Enhanced Protection Mode Disabled

  • Enhanced Protection Mode Enabled
    1. Screenshots of related CIS event logs: No related CIS event logs for this problem.
    1. A CIS config report or file: Current configuration file uploaded here.
    1. Crash or freeze dump file: No dump file produced as application does not crash or freeze.
    1. Screenshot of About page. Can be used instead of typed product and AV database version:

C. Your Setup

    1. CIS version, AV database version & configuration: See screenshot above
    1. a) Have you updated (without uninstall) from a previous version of CIS: No
    1. b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
    1. a) Have you imported a config from a previous version of CIS: No
    1. b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
    1. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Other than the option causing the problems being described, no.
    1. Defense+, Sandbox, Firewall & AV security levels: Deafult settings used. Defense+: Safemode, Sandbox: Enabled with Default Settings, Firewall: Safemode, AV: Stateful.
    1. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Home Premium Service Pack 1 64-bit, Version: 6.1.7601 Service Pack 1 Build 7601, Enabled - Default: Notify me only when a program trys to make changes to my computer, Administrative account.
    1. Other security and utility software currently installed: Malwarebytes with Realtime protection disabled. Used as on-demand scanner only.
    1. Other security software previously installed at any time since Windows was last installed: No
    1. Virtual machine used (Please do NOT use Virtual box): No

Any assistance with this problem is appreciated.

[attachment deleted by admin]

Thank you very much for your bug report in standard format.

Unfortunately the following items of required information are missing from your post

    1. Other security software previously installed at any time since Windows was last installed: -
    1. Virtual machine used (Please do NOT use Virtual box): -

We would be grateful if you would add these items of information so we can forward this post to the format verified board. You can find assistance using red links in the format and here - if you need further help please ask a mod. If you do not add the information after a week we will forward this post to non-format. If this happens we will tell you how to rectify this if you wish to. Developers may look at the issue in the non-format board, and may fix it.

But it is much more likely to be fixed if you edit your first post to create an issue report which meets all criteria in the bug forum Checklist and Format. (You can copy and paste the format from this topic). The general reasons why are summarized in that post, the reasons we ask for information you may think unecessary are given in this detailed post.

In the current process we will normally leave it up to you whether you want to make a report which meets all the criteria or not. We may remind you if we think a bug of particular importance.


I am slightly confused because those questions are both answered with N.A. No security software. Was previously installed and no other sandbox is used.

Both questions are answered so I am not sure what other information you require.

Please reply Yes or No if Yes please supply details

N/A is taken as Not Applicable

Thank you



No to both. However the questions are written in a fashion that implies more than a yes or no is required.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Moved to Verified.

Many thanks again



I am unable to modify links to the images in the previous post, therefore I am posting them again here:

By foddersin at 2011-12-01

By foddersin at 2011-12-01

By foddersin at 2011-12-01

I have the same problem described here. Any news on this?