Bases.cav not downloading

I restored Windows 10 partition image on my laptop. The partition image is from some month ago. Windows and Comodo obvious needs to be updated. I not want to connect to internet with my laptop while Comodo tells me that I am “at risk”. So I am trying for several days to download the file “bases.cav” from Comodo website on my desktop computer, so I can transfere it to the laptop and import virus database on Comodo. Problem is, almost at the end, the download of bases.cav fails. I click on “resume” and it seems like it finalizes. The size of the downloaded bases.cav is 504.672 KB. When I try to import the virus database on the laptop it gives an error on “install signatures”. Looks like the file is not complete. Tha Product Version of Comodo is Any idea how I can download the complete bases.cav ?

add in settings host url:
see image

I am trying to download the file bases.cav from Comodo website using Firefox. This is how I always did, but not its failing at the end of the download. This is the link I am using for many years:

I just downloaded the full database from that link using Firefox w/o any problem and it gave no errors. I’d suggest trying another PC for the download if you have one

Thanks for your reply. This is very strange. I tried again 4 times today to download bases.cav, once in another computer. All fail at the very end. When I click on “resume” it saves bases.cav with 504.690 kb. When I import it into Comodo, it gives error at “Install signatures”.

Solved my problem. I downloaded the newest standalone version of CIS and installed it. I tried to import bases.cav that I just downloaded, but it gave error. Lucky I had a file bases.cav from April 2020, tried to import that, and this worked. So I only had some more updates do download.