Backup script using runtaskafter with commandline options [solved]

I have downloaded and installed RC and try to run my existing scripts.

These scripts work fine except for the option runtaskafter.

My syntax is …
/runtaskafter “|xcopy.exe| \mynetpc\Backupvol\FullHdiskImage.log \mynetpc\Backupvol\maillog.”

This worked in the 3.0 version but now i get an errorbox saying
Windows cannot find ‘|xcopy.exe| \mynetpc\Backupvol\FullHdiskImage.log \mynetpc\Backupvol\maillog.’, Make sure you typed the name correctly, and then try again.

tried with version 4.06.12 and this gave the same result

I am running comodo backup on a windows 7 64 home premium OS system

Try to remove the “|”
/runtaskafter “xcopy.exe \mynetpc\Backupvol\FullHdiskImage.log \mynetpc\Backupvol\maillog.”


allready had tried that… The | is in bcs it was needed the previous version
now it does not work anymore with or withouth |

The issue will be fixed in an update which will be available tomorrow.
Until then you can create a separate .bat file with the xcopy command(s) and set it to run after backup:

/runtaskafter “C:\BatFile.bat”


Thank you very much for the reply.
I was allready using this workaround.
Looking forward to the fix, and will report back if it fixed this issue.

I have tested my script with the new version and can confirm that the issue has been solved.
My old script works again.

Thank you very much !

For anyone reading this, be aware that you have to use it like the example below, if you want to use command line options. Like

/runtaskafter “|xcopy.exe| \mynetpc\Backupvol\FullHdiskImage.log \mynetpc\Backupvol\maillog.”

You cannot leave away the " | "

I’m glad it works :slight_smile: