Azureus - all incoming TCP being blocked

I installed COMODO recently and I need help.
No matter what I do, all incoming TCP traffic for azureus are blocked. I read a few topics here, tried to make different rules, but nothing worked. Even “Allow tcp/udp, in/out, any…any…any…any” and “trusted application” has no affect.
In Global rules are only “allow all outgoing/incoming … local area network” and “block icmp … where icmp messageecho request”

I was using SYGATE and win SP2 firewall before and everithing worked fine. Im running on XP sp2 and using router (nat/port redirection is ok)

Can anyone hepl me?

edit: the joke is, even if i set the firewall security level to disabled, its not working …

Your router is what matters. if your router is set up properly for Azurees and properly port forwarded then simply make Azureus a Trusted programs under the firewall and D+. Thats what I do for uTorrent.

I repeat, router is not the problem.
Azureus worked for 8 months with this router properly until I uninstalled sygate firewall and installed comodo

besides that, “firewall events” is full of blocked incoming tpc conections…

Are you sure you uninstalled Sygate properly? Can you post your logs? Did you try doing what I said?

After uninstalling comodo, (and no other firewall instaled) azureus started to work. Still displays “firewalled”, but im able to download. While another software requireing NAT works perfectly, part of the problem seems to be on azureus side.

as I wrote in my first post, seting azureus as trusted program has no affact. comodo was still blocking all incoming tcp.

where can i find these logs?

If you set Azureus to Trusted in the Firewall and D+ then it should work period. Your logs are very easy to see. Go to Firewall\Firewall Events. Did you set it to trusted in both areas of Comodo? You can also try putting the Firewall and D+ in Training Mode for a bit.

ok, so I uninstalled sygate firewall (second time), instaled comodo again, set azureus to trusted and it seems to work. no idea what was causing problems before. maybe some problem with uninstaling sygate / instaling comodo

azureus suddenly decided nat is ok (minute before or with no firewall instaled it was showing “firewalled”), down speed is good, but i still get some (about 20 per minute) blocked incoming tcp

Date/Time	Application	Action	Source IP	Source Port	Destination IP	Destination Port
8.9.2008 23:22:04	Windows Operating System	Blocked	89.156.173.**	55502	200**
8.9.2008 23:22:07	Windows Operating System	Blocked	125.224.208.**	2976	200**
8.9.2008 23:22:10	Windows Operating System	Blocked	89.156.173.**	55502	200**
8.9.2008 23:22:16	Windows Operating System	Blocked	125.224.208.**	2976	200**

it is ok?

and thank you for your time :slight_smile:

You can try changing the port Azures uses but the Windows being blocked is normal. See this thread.