AVG updates

I am a VERY newbie and I have searched the boards for this answer, and found some information, but I am unable to follow it because it instructs me to do things I don’t know how to do. So I am posting this question in the hopes someone can give me (in baby steps) instructions on how to solve my problem. I have been getting the following message from AVG free edition ever since I installed Comodo,that “No updates are available so the update process can’t be finished.” Please have patience with me. I am trying!

You need to add AVG updater to the firewall and D+ rules. You can also leave firewall and D+ in training mode and set AVG to update at a time where you can watch it.

Okay, I found the screen for the firewall that says, “Define a new trusted application” and I clicked on that. And then I browsed until I got to a my AVG7 folder. There were a gazillion files in that folder. How do I select them all? Also Where under the D+ tab do I find the place to add the AVG? Thanks!

NO,NO,NO I never said select them all. Just put firewall and D+ in training mode for a day or so and let Comodo learn AVG. You can manually add just the “AVG updater service” by going into Firewall\Advanced\Network Security Polciy then clicked on add. Make it trued. Do the same for D+.

Now, now. Remember I warned you and I asked for your patience. I’m not TRYING to be stupid! (I can just hear your response to THAT!) If I asked you to do things I’m proficient at, but you are not, you’d feel stupid too! Sorry, I was getting a bit defensive there, when you are trying to help me. Back to the question.

I got as far as clicking on “add” but you lost me when you said make it “trued”. Make what trued, and how do I do that? How do I find the AVG updater service.


The AVG updater service should most likely have something with “update” in its name. When you’ve found the right one, select Use a Predefined Policy and then choose Trusted Application.
Else, just set Defense+ to Train with Safe Mode, and do a manual update :wink:


I had both in training in safe mode when I got this message. I changed it them both to just training mode, and I still got the same message.

Try deleting all the rules in Network Security Policy and Computer Security Policy for the AVG Updater, then do a manual update.

How long time ago was it since you installed CFP 3? If it was installed just a few days ago, there might actually not be any updates available at all (check this by running a check for updated with Firewall and Defense+ disabled).


Don’t set to train with safe mode. That will still give you a D+ pop up alert if your not around to see it. Set both firewall and D+ to training mode. I had this problem years ago when I used AVG and Comodo 2.4. The maual updater is different then the auto updater. All I did was set AVG to update at a time when I know I was gonna be on my computer. Then when AVG updated I got an alert from Comodo and I clicked Allow. You can try that.

AVG updates two or three times a day or more so there should be a update available.

Ragwing - I did just install it a few days ago, but I’m getting a message from AVG that it needs to be updated.

Also, since I’ve changed from Training in safe mode to just training, I keep getting error messages from Comodo that says it found a bug and needs to shut down. ARRRG!

The dat files update. The updater program stays the same. Also AVG free only updates once a day. Thats why its free.

Ragwing - I found the Network Security Policy tab and there were two rules pertaining to AVG. The first was for avgw.exe and it said “allow all request.” The second was for avginet.exe and it said “allow IP out from IP any to IP any where protocal is any.” I removed the second one. Where do I find “Computer Security Policy”?

Go to D+\Advanced\Computer Security Policy.

Okay, I found it. There were about 5 or 6 of them, and I removed them all. Then I tried updating again, and got the same message. Then I restarted the computer and tried updating again, and still got the same message. What now?

BTW, thanks for sticking with me here. I really appreciate it!

Its really not that hard. I have over 200 programs to learn when I install any firewall. Thats why firewalls have a learning mode. As in matter of fact Webroots firewall stays in learning mode for a week by default.

Yes, but it doesn’t seem to be learning correctly. I keep getting that same error message.

What message are you getting? After you removed them did you click “apply”? Are you using “training” mode and not train with safe mode.

Yes, I hit “apply” in both cases, and I am in training mode, not safe mode. The message I am getting from AVG is “No updates are available so the update process can’t be finished.” And since I’ve changed to training mode, I’m getting a message from Comodo that they’ve found a bug in the system and have to shut down.