AV scan causes comodo helper service to stop.

Last night during routine antivirus checking I ran into the same issue others were.


I had that issue followed by


when I tried to close the scanner.

I tried uninstalling CIS to reinstall per suggestions in these and other threads on the same issue.

I downloaded the file CIS_Setup_3.13.125662.579_XP_Vista_x32 since I run Windows XP Professional 32 bit.

After running install, choosing language, accepting license, choosing install path (Default), having files installed, opting out of providing email for spammail, leaving the checkboxes for just firewall and antivirus install checked, opting out of threatcast, unchecking the 3 bundled software packages (I hate that these are autochecked, should be opt IN, not out)…

At this point it configures some files like firewall kernel and such, then immediately after it does a “Rollback” it seems and ends with a COMODO Internet Security Installer error message of “Problem with deleting the shortcuts. Please kindly delete the Shortcuts manually.”

I have attempted multiple times to uninstall with the clean-up tool as well as manual uninstall located in the following links.



Nothing has worked and I no longer can install CIS.

Let’s see if we clean the playing field. Start with what follows. The tutorial is to look for previously uninstalled security programs. Use it to look for a CIS related driver.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Next step is a manual removal tutorial.Forget about removing the legacy keys as they are too much a pain to remove.

Uninstall CIS and reboot. Then run [url=http://system-cleaner.comodo.com/]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See: https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_info-t17220.0.html;msg119226#msg119226

Now you should be good to go

It took a while for a response. I have since fixed the problem…in a manner of speaking.

I was able to reinstall by downloading and running revo uninstaller to remove all files/registry keys for Comodo.

Running an AV scan again crashed with an event log of “The COMODO Internet Security Helper Service service terminated unexpectedly.” When this occurred Comodo showed the same “no interface” error, and when closing the scan it gave the “no resources” error.

Restarting the service allowed the firewall to run fine, but every single scan has the exact same problem.

Edit by EricJH: I merged your two topics. Please don’t cross post. When a topic doesn’t get attention you are free to bump it every 24 hrs. No need to start multiple topics.

In this thread: https://forums.comodo.com/install-setup-configuration-help/major-problems-t50319.0.html

I had an issue with antivirus scan causing the comodo internet security helper service stopping unexpectedly. Before I knew that was the problem I attempted to uninstall/reinstall and had to download a 3rd party application to remove ALL traces of the program (Revo Uninstaller for those wondering).

After finally getting the firewall reinstalled the exact same error is occuring every single time I attempt a virus scan. Every scan attempt stops the service and throws the errors in the above thread.

Restarting the service allows the firewall to work again.

Current CIS version: 3.13.126709.581
Virus signature database version: 3659
Note: Clean system reported via virus scan bootdisks: Kaspersky, Bitdefender, Avira. Nothing detected.

No one has any response?

Still nothing?

Yet another day…

I have had the same as reported here

Lots of help elsewhere for those with slow systems. No help it seems or acknowledgement of CIS crashing.

Still no help. Still no AV scans…

That’s because the forums are mainly just users. Users who don’t have the answer for you.

I think your best bet would be to open a support ticket here. Comodo Support.

This thread can be closed then. Issue unanswered.

Such a shame. Guess I will simply have to use a different AV solution. Comodo is not for me. I will also have to recommend to others that they avoid the AV portion of Comodo.

The firewall works great, but the AV leaves a LOT to be desired.

  1. Virus definition updates being unable to be automatically updated requiring manual intervention.
  2. Random bug that causes entire helper service to stop automatically with random error messages that have NOTHING to do with the problem. “Interface not supported” and “No system resources” is nothing near the actual problem of “Comodo Internet Security Helper Service” has stopped unexpectedly.
  3. Uninstallation was a nightmare requiring the use of a 3rd party application (Revo Uninstaller) in order to actually uninstall as the Control Panel could not uninstall properly.
  4. Re-installation attempt before Revo Uninstaller stopped and “Rolled Back” with no error message as to what the problem was. (The answer is left over registry entries that Comodo itself does not uninstall)
  5. And finally, support website being unable to be used for the product I have installed because “Other” tries to open a support ticket about certificates.

It’s unfortunate. I would much prefer to have both Firewall and Anti-virus in a single source.

Amazing that the link there only shows version 3.13.125662.579. Especially since I until recently had 3.13.126709.581 and JUST updated to: 3.14.129887.586 even though I have “Automatically check program for updates” checked, manual check for updates got me to that version.

Another failure in automation requiring manual intervention…Additionally, this update, would it have actually occured would have fixed my “Service” problem.

Amazing that this update has magically fixed my problem. What date did this update occur? It’s not on the release notes, it’s not automatically updated, and only recently has it been available.

Simply stunning…

What was the result of your ticket on the official Support Centre (https://suport.comodo.com)?

I did not post a ticket.

The only options under “Select product” are:

  1. Comodo Enterprise Sales
  2. Comodo ESM Support
  3. Comodo CCM Support
  4. Comodo Internet Security Pro
  5. Customer Feedback
  6. Comodo Secure DNS
  7. EasyVPN
  8. Certificates
  9. HackerGuardian
  10. HackerProof
  11. PC Security Software (I did not notice this one, Is this the same as CIS?)
  12. UserTrust
  13. TrustConnect
  14. Two Factor Support
  15. Validation Docs
  16. Account Changes
  17. EV Validation
  18. Other

I didn’t notice #11, but it still does not say “Comodo Internet Security - CIS”. Perhaps this would have been where to submit.

Choosing 18 tries to submit a ticket under 8. Certificates.

Either way, the update that occurred yesterday, and manually updated today (Failure of automatic update) has magically fixed the problem. AV scan did not unexpectedly stop the service and no random useless error messages. Scan completed.

Of course, the release notes page does not show this as the current version, in fact, it didn’t have my previous version and only had a version previous to that.

Support tickets for CIS (as opposed to CIS Pro) can be lodged under category 4.

FYI - it’s a strange system. When you lodge a ticket is it classed as OPEN. When Comodo respond, it is classed as CLOSED. This DOES NOT mean it is ended, just that Comodo can’t do anything until you respond by re-opening the ticket and entering the requested info. As I said - a bit whack, but it works.

FYI2 - As previously posted, Comodo have been advised on the disparity between the update version and the web site version.

Ewen :slight_smile:

I shall remember that for future use (#4).

Does Comodo also know that for some reason users like myself are not having automatic updates? I only updated today because someone mentioned 3.14 as the newest version, and I had to manually check and sure enough, there was an update.

Under MISCELLANEOUS → SETTINGS → GENERAL is “Automatically check for updates” selected?

Yep, as stated in my “Amazement” post, it is indeed checked. Still is after the update.

Strange that you can manually update but can’t autoupdate, as they use the same processes and connections. I’ll flag this and check with the other mods.

[/amazement off]
[waiting on] :wink:

Ewen :slight_smile: