Assembly-UnityScript.dll false positive.

I don’t have permissions in my browser to access the file anymore, even as administrator, this is part of the problem. I have not found a way to submit the file besides using the Submit as False Positive option in the virus scanner, but that doesn’t let me add any comments(and I don’t know if that is working either due to no confirmation dialog if the file was properly sent or not).

The original file name is “Assembly-UnityScript.dll”. It is part of the Unity 3D code compiling process.

Unity 3D makes a copy of this file every time a project is opened, so I cannot just make an exception in the list because each time I open Unity, it will make a new version of this file. Since Comodo blocked access during Unity’s permission settings, I cannot access, copy, or do anything to the file anymore.

Once Comodo locks the access, I cannot get Unity to read it again, even after I add the file as an exception or “trusted file”.

I haven’t found a way to get Unity 3D to compile anything again. I’m still troubleshooting Unity 3D to find a fix for this. More then likely, when Comodo first got set off, it probably “cleaned” some vital part of the code compiler that is now missing, or otherwise locked down and broke something.

I will see if I can get a copy of this dll file, but I must add that since Unity 3D builds this file each time(it’s a different file size for each project depending on what is being used in code), I don’t know how helpful that can be.

The false positive ID in the scanner is TrojWare.Win32.ZeroAccess.BQ@285601180

I will post the file once I figure out how to get access to a copy of it again. Once Comodo scans the file, I cannot get to it to upload the file due to permission errors (caused by Unity’s compiler being unable to set it’s file permissions correctly during the lockdown.)

If you can, please submit it as a false positive via this site.

I apparently don’t have permission(running as administrator here) to allow the file to upload. I get a “please upload files bigger then 0k” error, because my browser cannot read the file.

I’m not entirely sure why yet, but the only operation I am allowed to do on the file is delete it and let Unity build a new copy of it. I’ve got a support thread over on the Unity 3D forums to ask if this is normal behavior for Unity. (Normally when using Unity I don’t touch these files at all, so I’m operating a bit blind here.)

And yes, all the windows permissions have been set to allow me to access the file, and I am running as Administrator. Something still is blocking me from doing it though.

I’ve already tried closing Comodo to get to it, and the result is the same(only allowed to delete, not copy or access it).

I will continue trying to get a copy of this file to you.

Can you copy it to the desktop and then upload it?

Nope, I can’t copy the file anywhere, I don’t have permission to access it.

I even tried going into Command Prompt as Administrator and doing a Copy command. I get this message:

“Access is denied.”

I’ve already tried to set permissions to allow me to access it anyway. (Both through the command prompt and through windows 7’s user interface.) Win 7’s interface tells me it’s already been set, but won’t do anything with the file except delete it. And the command prompt method of setting file permissions just results in the same Access is denied error.

The weird thing is that, even as a user, I can delete the file just fine. Also, Unity is having no problem recreating it from scratch when I do so. But nothing (including Unity) can actually access or do any operation on the file(or any new copies of it) besides deleting or creating it.

Comodo can scan and report the false hit, but I don’t know if it is able to submit the file or not. The upload window goes away too fast for me to see anything, so I’m guessing Comodo can’t get to the file either.

Attempting to upload the dll file as a zip, since I can’t upload the dll file itself.

That did it. I had to restart the computer and then disable the antivirus to be able to run Unity and successfully grab the file.

The file in this zip is the one that causes the false positive. As I said above, it’s a dll file that Unity creates during it’s code compiling process, and Unity needs access to the file in order for the compiler to function. I’ve been using Unity for almost a year now and haven’t had this problem till yesterday.

The only thing I added to my own code in Unity before and after the false positive was some javascript to keep track of an array of data for a level grid. No file writing/reading or anything else besides keeping variables in memory. I don’t know if that is relevant to the issue, but I figure it’s better to list out as much info as possible.

[attachment deleted by admin]

Hello 300happy,

Thank you for reporting this. The False Positive will be fixed soon.

Best regards,

I got the same problem yesterday (22.4.2014)!
The “virus” detected is TrojWare.Win32.Krap.T@101925166, in the file Assembly-UnityScript.dll.
Unfortunately I do not have the exact same version of the file anymore, as it is dynamically generated by Unity.
It seems that the false positive comes up only sometimes when compiling, not always.

Please fix this false positive, I will have to remove Comodo unless I can fix it some other way…

Hi juhoeric,

Please submit the detected sample to us so we can check them.

Yuvaraj M