Are Comodo DNS servers down?

Encountered a strange problem for the last few hours, I couldn’t get Comodo Dragon to load any pages, kept getting the Error code: ERR_NAME_RESOLUTION_FAILED message, which is weird because Firefox runs without any problems and I have both browsers set to use Comodo DNS. So I did a little experiment and went into the settings of Dragon and unchecked the “Enable malware domain filtering (Comodo Secure DNS)” box, then reloaded the page and it worked no problems, so my question is, are the servers down?

OK I did some tests, it would seem they indeed are down, oh well, looks like it’s back to Open DNS, LOL.

For what its worth ( if anyone even visits this part of the forum anymore ) …

Experienced the same problem a few times over the last week. More annoyingly in the last two hours today

Turn off Secure DNS in Comodo Dragon, and the internet works fine.

Also experiencing redirects to Cloud Flare on page load errors. When did that rubbish get introduced, if I get a page error I want to see a page error, not a frigging redirect. Stop messing with the way things are supposed to work

So to make this clear

I have set my Primary and Secondary DNS as per instructions here …

And I have turned off Comodo Dragon Advanced setting …
“Enable Malware Domain Filtering ( Comodo Secure DNS )”

And the internet works fine

If I turn on the advanced setting in Dragon, a lot of page loads do not work at all, and I end up getting redirected to that Cloud Flare rubbish

^^ Is anybody out there … helloooo !

Just had to disable my Secure DNS settings in IPV4 properties, and in the Dragon browser, because today I am experiencing complete loss of internet again when using Comodo Secure DNS

Will it ever be consistently reliable ?

For me too. But since Comodo DNS is on my Cisco router, all my enterprise network was down. Hopefully it was easy to diagnose, but come on Comodo… This is ridiculous to have BOTH DNS servers down !!! This is unacceptable.

Hi Guys,
I am not experiencing the issues here, but I will try to find out more from Staff about this issue.
Maybe Geo-location specific?


Edit: I have sent a PM to Staff.

Excellent, thank you.

It could well be location specific, the thought had crossed my mind considering very few people are reporting it and by default the Comodo Dragon setting is asked and by default selected to be on … So you would imagine a large percentage of Comodo browsers to be affected who typically accept defaults.

But there is also the strange behaviour I have experienced whereby turning off the setting in Comodo Dragon - But still having the windows IPv4 Primary and Secondary DNS settings …

… was working fine

Then today, it does not matter which one I use, both the Dragon setting and IPv4 settings both break the internet, so today it looks like its a server problem that is also geo influenced.

Whereas yesterday it seemed to me that the Dragon setting does something differently than setting the IPv4 Primary and Secondary DNS, because the latter was working when the former was not.

So there are two questions really

  1. Is it a server issue ?


  1. What does Dragon do differently when you apply its Setting for Secure DNS, than setting the IPv4 settings does - Does it perhaps use a different set of Primary and Secondary DNS addresses than / - In which case I thought that those addresses were supposed to be the ones we are using these days as mentioned in this following topic …

… Didn’t really get a definitive answer there.

It was out for a few hours this morning for me as well. Currently it seems to be working as it should now that I re-enabled it in CD.
Luckily the issue was easy for me to pinpoint this morning, since I was using both Opera and CD at the same time, with Opera having no issues.
For what it’s worth, I’m in West Virginia. Finding the location of the others who were knocked offline by it could give some insight into whether or not it was a geo-locational issue.
Hopefully they can get this ironed out quickly.

North UK here

In Brazil, I have had problems with Comodo DNS servers today, a few hours.
I have Comodo DNS servers indicated in the router; then, it was impossible to navigate in internet with all browsers. When I had substitute Comodo DNS servers by others DNS servers, my internet has became operational again.
It seems Comodo DNS servers was down meantime?

Until someone gets back to us …

I have a long term solution for these occasions when Comodo Secure DNS cannot be relied upon

Its a bit of messing about but once done you can forget about it - Follow the advice on how to manually set your Primary and Secondary DNS servers via windows :

BUT - When you get to the last screen ( where you manually input the addresses ) … Dont stop there - Click Advanced

Now at the top of the next window click the DNS tab ( if you dont know what I am talking about at this point you are not in the right place, you should be looking at something similar to the screenshot below I have uploaded …

And then click Add - Enter the individual DNS server addresses one by one

first Comodo Secure DNS, then the second, then choose a couple more from another free DNS server project like the OpenNIC project
( on its home page four OpenNIC DNS servers which have been determined to be closest to you will already be on that web page )

Once they are all entered, they will be tried by your machine in the order that you entered them, and quickly move on to the next if the first one tried fails, so even if Comodo’s secondary one fails at the same time as its primary ( as we have been experiencing ), then it will move on to the third and fourth ones. I setup the two Comodo ones, plus one OpenNIC server in the UK, two from France and another from the Netherlands across the water as backup choices. Works a treat and my connections since have been consistantly fast - But more importantly reliably working for anyone. There are more OpenNIC servers to choose from here
( I would have a revisit to that page periodically to see if there are any changes to available servers )
A lot of them also have logging completely disabled.

One additional thing, now that you have setup four DNS resolvers or more to be tried in sequence by your machine when one fails -

You do not want Comodo Dragon / Chromodo to be overriding those with its own Comodo Secure DNS setting, so go into the browsers settings, scroll down to Advanced Settings and click on it, then scroll down to the Privacy section …

… And deselect “Enable Malware Domain Filtering ( Comodo Secure DNS )”

If you dont deselect that, the browser will have preference above your machines settings, so you will only be using the two Primary and Secondary DNS addresses, instead of the four ( or more ) that you have set in windows settings for your whole machines communications.

[attachment deleted by admin]

Lately I have the same problem. Internet not working at all in Comodo Dragon unless I disable “Enable Malware Domain Filtering (Comodo Secure DNS)” in settings. Comodo IceDragon and everything else works fine.

This webpage is not available


The server at can’t be found, because the DNS lookup failed. DNS is the network service that translates a website’s name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Comodo Dragon from accessing the network.

CIS installation changed my IPv4 DNS address into while here: Free Comodo Secure DNS | Best DNS Security Solution 2022 is another one: Which one is good and what DNS CD is using?