Application Rules Bug (v3.0.25.378 x32)

AMD Sempton 32bit
NOD32 v2.70.39

I’m creating rules for Call of Duty. I’m allowing certain UDP In connections. I add destination port 25000, it goes ok. But, when I enter a new rule for port 25010, Comodo alerts me that a rule for that setting already exist. But it doesn’t. Here’s a screen shot of the rules:

Also, if I try to edit the rule with the port 25000 and change it to e.g. 25002, it doesn’t save the change when I hit the apply button. I have to change it to something else first (e.g. ANY port), apply, and then edit again with the desired port.

I am a hardcore gamer and never needed any specific rules for any game. Even COD4. See my thread here.

I prefer to make the rules myself :wink:

I had that happen here, too, after an update. Maybe the settings had become corrupted. I solved this by deleting the application from the rule set and define new rules.

Hmm, this was a clean installation and I was creating the rules from scratch.

Confirm that i’ve seen this before, i was absolutely sure the rule did not exist and cfp alerted me though.
Vista SP1 UAC 3.0.25

Hi all,

We’ll check the issue in our lab.
Thanks for your feedback.

Great to hear from you guy’s, well wait.
Any idea when the next update will be available ?

When it’s ready.

Egemen & the tream are still fixing bugs.

In what mode your CFP is running when you get this issue?
Is Call of Duty already running and someone is trying to connect to it when this happen?


I’ve had this when manually adding a rule for firefox, and i’ve checked it twice but the rule did not exist.
At least not for Firefox.

Firewall was in Custom Policy Mode, Alert Frequency Level Very High.

Call of Duty was not running at the time. It hasn’t been run at all in the last couple of months.
This is not a one time error. It shows every time I edit CoD settings.

And this is not the only bug! I’ve just tried to add a couple of other applications to the rules. It doesn’t matter what application it is. Every time I add a UDP In rule for some port, the following UDP In rules show a warning that the entry allready exists. No other rules are set at all for the application, just these UDP In rules. It doesn’t matter what ports I enter, it’s allways the same.
Now the interesting part…if I try to edit one of the rules I was warn about and change the port number, it repeats the warning but saves the change if I click Yes. But, if I change the port in the first UDP In rule, it doesn’t show a warning but it doesn’t save the change at all! It could be related to the bug that many people have, about not applying the rule name changes.