Apache (through XAMPP)

I’m running a website which I test locally (using Apache) before uploading it to the server. before installing CPF it all was working fine but not afterwards. so I did configure it just like it has been suggested in several posts. after playing around a bit I got it to work…once (yesterday). my configuration is as follows:

skip TCP loopback connections
allow zone to zone (home network) from any port to 80 (tried any port, too. no difference. also tried my ip to my ip)
allow programs: apache.exe, httpd.exe, php.exe

I restarted after every change of configuration, made apache a service…usually I got a response from the XAMPP program whenever I tried to start Apache, like “running”. now, whenever I click the “start” button: nothing
is this a bug or have I been drunk unknowingly?

thanks to everybody willing to help a network newbie

that network monitor rule has been above the “block all” rule all the time

Welcome to the forum.
Have you set your network monitor rule as just IN? If not, do that.
Can you see any blocks in the log?
Have you installed with auto?
Have you changed any net. mon. rules from default?

Finally, I have found the root of evil: Skype. I haven’t had it running that one time I was able to run Apache. But when Skype is running, I cannot start it.

I checked out Skype’s settings and there is an option to use ports 80 and 443 as alternatives for incoming connections. By the way, it is activated by default. I hope this info helps others, too.

Thank you anyway for your support AOwL.

I think I have set my Skype to use another port than the default (80,443), and I have made a in rule for it to see how it works.
Thanks for your input as well. ;D