Apache 2.2 blocked by Comodo


Been using Comodo for a couple of months now and really like it but recently i’ve had the need for an apache web server which i can’t seem to configure with Comodo.

I know it’s the firewall because if it’s off it’s possible to connect to the website and when it’s on…well i can’t.

I tried this rule:

Action :allow
Protocol: TCP or UDP

Source: Any
Destination: Any
Source Port: 80
Destination Port: 80

I set this to rule number 3 but no joy. I’m stuck for what to do. Tried searching this forum and google but not found anything relevant…

Thanks in advance for any help. If you need more information please ask.

Hi Audiofreq, welcome to the forums.

I know zip about Apache 2.2, but I can see that you need at least 2 rules. This is because both source & destination ports are unlikely to be 80 at the same time. The IN rule would have a destination port of 80 and a source port of Any. An OUT rule would have (I assume) a source port of 80 and a destination port of Any. Then, theres HTTPS… TCP Port 443.

Hey thanks for the quick reply and the welcome!

I just change my IN/OUT rule to just IN and used to rule you said (source ANY, Destination 80) and it works!!

Would I really need to use the OUT rule?

No problem. I don’t think so… that’s probably handled by the Application Monitors rule on Apache. You can probably also restrict the rule further by limiting it to TCP… I don’t think a web server uses UDP on 80.

edit: did some reading. :wink:

Ah wow thanks very much!!

Can confirm that i have changed it to TCP only and still works fine.

What a pro!