Antispam 2008 Install Issues

I have had CAS 2005 running for some time without issues. Then my machine began notifying me that 2008 was available (every time I rebooted). Today I downloaded 2008 and ran the install. It said “In case you have any incompatible products installed, please uninstall that before installing Comodo antispam”. Then it exited without installing. So I manually un-installed 2005 (V1.1), rebooted, and tried again. The same problem happened again. Exact same message. I have Comodo Firewall and Antivirus installed. No other competing products are installed. So I re-installed V1.1 without issues and it’s working fine again, except that I still get the notice about the new version of CAS with every reboot. I read the other posts here and thought that this issue was fixed with the Sept 10 release of CAS 2.1?

So my questions are:

Was this issue fixed with V2.1?

Why might it still be happening?

Is there any way to disable the “Update Available” message in version 1.1 every time I reboot?

Thanks so much,


What appears to be happening is that when you Uninstalled the original version, some directories with information were left on your computer.

Your best bet is to uninstall again and search your computer for anything labeled COMODO and then remove those directories, providing you don’t have any other comodo products installed.

if you do, simply search your C:/Documentsts and settings/ all users/application data/Comodo Directory as well as the C:/documents and settings/USERNAME/Application Data/Comodo AND your C:/Program Files/ Comodo Directory.

I can’t recall where it leaves a folder but it’s one of the above 3.

Then run a Registry cleaner like “Comodo registry Cleaner” to remove any invalid entries and then do a fresh install of 2008 version.


Hi Biddyding:

 CAS 2.1 has been modified to work with Comodo Secure Email 1.x.
 But it could not work with Comodo AntiVirus 1.X and 2.x. The coming release Comodo Antivirus3.0 will fix this compatibility issue.
 If you want disable the "Update availalbe" message, it has not UI element set this. But you could do it manually.
 1. Run "regedit" by Start->Run.
 2. Open HKEY_LOCAL_MACHINE\SOFTWARE\Comodo\ComodoAntiSpam
 3. Modify "CurrentVersion" vaule to "2100", then save and exit regedit.
 This will block prompt of "Update availalbe", and it will works version before 2.1, including 2.1.

Thanks for the help guys!

I Appreciate it!

I have gone and disabled the upgrade notice for now, and will try reinstalling again after the holidays (getting busy).